CVE-2022-3509 is a high-severity (CVSS 7.5) Uncontrolled Resource Consumption vulnerability in com.google.protobuf:protobuf-java. A fix is available for com.google.protobuf:protobuf-java — see the affected versions and patch details below.
Parsing issue in protobuf textformat
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2022-3509.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
com.google.protobuf:protobuf-java☕com.google.protobuf:protobuf-java☕com.google.protobuf:protobuf-java☕com.google.protobuf:protobuf-java☕com.google.protobuf:protobuf-javalite☕com.google.protobuf:protobuf-javalite☕com.google.protobuf:protobuf-javaliteReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
A parsing issue similar to CVE-2022-3171, but with textformat in protobuf-java core and lite versions prior to 3.21.7, 3.20.3, 3.19.6 and 3.16.3 can lead to a denial of service attack. Inputs containing multiple instances of non-repeated embedded messages with repeated or unknown fields causes objects to be converted back-n-forth between mutable and immutable forms, resulting in potentially long garbage collection pauses. We recommend updating to the versions mentioned above.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | com.google.protobuf:protobuf-java | ≥ 3.0.0&&< 3.16.3 | 3.16.3com.google.protobuf:protobuf-java:3.16.3 |
| ☕Maven | com.google.protobuf:protobuf-java | ≥ 3.17.0&&< 3.19.6 | 3.19.6com.google.protobuf:protobuf-java:3.19.6 |
| ☕Maven | com.google.protobuf:protobuf-java | ≥ 3.20.0&&< 3.20.3 | 3.20.3com.google.protobuf:protobuf-java:3.20.3 |
| ☕Maven | com.google.protobuf:protobuf-java | ≥ 3.21.0&&< 3.21.7 | 3.21.7com.google.protobuf:protobuf-java:3.21.7 |
| ☕Maven | com.google.protobuf:protobuf-javalite | ≥ 3.20.0&&< 3.20.3 | 3.20.3com.google.protobuf:protobuf-javalite:3.20.3 |
| ☕Maven | com.google.protobuf:protobuf-javalite | ≥ 3.21.0&&< 3.21.7 | 3.21.7com.google.protobuf:protobuf-javalite:3.21.7 |
Affected Products
protobuf-javagoogleprotobuf-javalitegoogleDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for com.google.protobuf:protobuf-java, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update com.google.protobuf:protobuf-java to 3.16.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-3509 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat JBoss Enterprise Application Platform Expansion Pack | see advisory | RHSA-2023:1855 |
| RHINT Service Registry 2.4.3 GA | protobuf-java | RHSA-2023:3815 |
| RHPAM 7.13.4 async | see advisory | RHSA-2023:4983 |
Frequently Asked Questions
Is CVE-2022-3509 in your dependencies?
Find it across Maven, including transitive dependencies.