CVE-2022-3171 — protobuf-java
MEDIUMCVE-2022-3171 is a medium-severity (CVSS 4.3) Improper Input Validation vulnerability in com.google.protobuf:protobuf-java. A fix is available for com.google.protobuf:protobuf-java — see the affected versions and patch details below.
Memory handling vulnerability in ProtocolBuffers Java core and lite
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2022-3171.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
com.google.protobuf:protobuf-java☕com.google.protobuf:protobuf-kotlin☕com.google.protobuf:protobuf-javalite☕com.google.protobuf:protobuf-kotlin-lite☕com.google.protobuf:protobuf-java☕com.google.protobuf:protobuf-java☕com.google.protobuf:protobuf-java☕com.google.protobuf:protobuf-kotlin+12 moreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Summary
A potential Denial of Service issue in protobuf-java core and lite was discovered in the parsing procedure for binary and text format data. Input streams containing multiple instances of non-repeated embedded messages with repeated or unknown fields causes objects to be converted back-n-forth between mutable and immutable forms, resulting in potentially long garbage collection pauses.
Reporter: OSS Fuzz
Affected versions: This issue affects both the Java full and lite Protobuf runtimes, as well as Protobuf for Kotlin and JRuby, which themselves use the Java Protobuf runtime.
Severity
CVE-2022-3171 Medium - CVSS Score: 5.7 (NOTE: there may be a delay in publication)
Remediation and Mitigation
Please update to the latest available versions of the following packages:
protobuf-java (3.21.7, 3.20.3, 3.19.6, 3.16.3) protobuf-javalite (3.21.7, 3.20.3, 3.19.6, 3.16.3) protobuf-kotlin (3.21.7, 3.20.3, 3.19.6, 3.16.3) protobuf-kotlin-lite (3.21.7, 3.20.3, 3.19.6, 3.16.3) google-protobuf [JRuby gem only] (3.21.7, 3.20.3, 3.19.6)
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | com.google.protobuf:protobuf-java | ≥ 3.21.0-rc-1&&< 3.21.7 | 3.21.7com.google.protobuf:protobuf-java:3.21.7 |
| ☕Maven | com.google.protobuf:protobuf-kotlin | ≥ 3.21.0-rc-1&&< 3.21.7 | 3.21.7com.google.protobuf:protobuf-kotlin:3.21.7 |
| ☕Maven | com.google.protobuf:protobuf-javalite | ≥ 3.21.0-rc-1&&< 3.21.7 | 3.21.7com.google.protobuf:protobuf-javalite:3.21.7 |
| ☕Maven | com.google.protobuf:protobuf-kotlin-lite | ≥ 3.21.0-rc-1&&< 3.21.7 | 3.21.7com.google.protobuf:protobuf-kotlin-lite:3.21.7 |
| ☕Maven | com.google.protobuf:protobuf-java | ≥ 3.20.0-rc-1&&< 3.20.3 | 3.20.3com.google.protobuf:protobuf-java:3.20.3 |
| ☕Maven | com.google.protobuf:protobuf-java | ≥ 3.17.0-rc-1&&< 3.19.6 | 3.19.6com.google.protobuf:protobuf-java:3.19.6 |
Affected Products
fedorafedoraprojectgoogle-protobufgoogleprotobuf-javagoogleprotobuf-javalitegoogleprotobuf-kotlingoogleprotobuf-kotlin-litegoogleDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for com.google.protobuf:protobuf-java, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update com.google.protobuf:protobuf-java to 3.21.7 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-3171 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat AMQ Streams 2.7.0 | see advisory | RHSA-2024:3527 |
| Red Hat build of Quarkus 2.13.5 | see advisory | RHSA-2022:9023 |
| Red Hat build of Quarkus 2.7.7 | protobuf-java | RHSA-2023:1006 |
| RHINT Debezium 1.9.7 | protobuf-java | RHSA-2022:7896 |
| RHPAM 7.13.4 async | protobuf-java | RHSA-2023:4983 |
Frequently Asked Questions
Is CVE-2022-3171 in your dependencies?
Find it across Maven, RubyGems, including transitive dependencies.