CVE-2020-36604 is a high-severity (CVSS 8.1) CWE-1321 vulnerability in @hapi/hoek. A fix is available for @hapi/hoek — see the affected versions and patch details below.
hoek subject to prototype pollution via the clone function.
Exploitation Status
No confirmed exploitation observed yet
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2020-36604.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
@hapi/hoeknpmhoeknpmDescription
hoek versions prior to 8.5.1, and 9.x prior to 9.0.3 are vulnerable to prototype pollution in the clone function. If an object with the proto key is passed to clone() the key is converted to a prototype. This issue has been patched in version 9.0.3, and backported to 8.5.1.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | @hapi/hoek | all versions | 8.5.1npm install @hapi/hoek@8.5.1 |
| 📦npm | @hapi/hoek | ≥ 9.0.0&&< 9.0.3 | 9.0.3npm install @hapi/hoek@9.0.3 |
| 📦npm | hoek | all versions | No fix |
Affected Products
hoekhapijsDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for @hapi/hoek, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update @hapi/hoek to 8.5.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-36604 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2020-36604 in your dependencies?
Find it across npm, including transitive dependencies.