NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦 npm
Not in CISA KEV

Prototype Pollution in @hapi/hoekGHSA-22h7-7wwg-qmgg

GHSA-22h7-7wwg-qmgg is a remote code execution vulnerability in @hapi/hoek. A fix is available for @hapi/hoek — see the affected versions and patch details below.

Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Aug 31, 2020 · OSV.dev, FIRST.org (EPSS)

Real-World Exposure

2 pkgs affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

612other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
@hapi/hoeknpm
39.4Mdownloads / week

Description

Versions of @hapi/hoek prior to 8.5.1 and 9.0.3 are vulnerable to Prototype Pollution. The clone function fails to prevent the modification of the Object prototype when passed specially-crafted input. Attackers may use this to change existing properties that exist in all objects, which may lead to Denial of Service or Remote Code Execution in specific circumstances.
This issue does not affect hapi applications since the framework protects against such malicious inputs. Applications that use @hapi/hoek outside of the hapi ecosystem may be vulnerable.

Recommendation

Update to version 8.5.1, 9.0.3 or later.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
📦npm@hapi/hoek≥ 8.3.2&&< 8.5.18.5.1npm install @hapi/hoek@8.5.1
📦npm@hapi/hoek≥ 9.0.0&&< 9.0.39.0.3npm install @hapi/hoek@9.0.3

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for @hapi/hoek, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update @hapi/hoek to 8.5.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-22h7-7wwg-qmgg is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Frequently Asked Questions

Versions of `@hapi/hoek` prior to 8.5.1 and 9.0.3 are vulnerable to Prototype Pollution. The `clone` function fails to prevent the modification of the Object prototype when passed specially-crafted input. Attackers may use this to change existing properties that exist in all objects, which may lead to Denial of Service or Remote Code Execution in specific circumstances. This issue __does not__ affect hapi applications since the framework protects against such malicious inputs. Applications that use `@hapi/hoek` outside of the hapi ecosystem may be vulnerable. ## Recommendation Update to v
O3 Security · Impact-Aware SCA

Is GHSA-22h7-7wwg-qmgg in your dependencies?

Find it across npm, including transitive dependencies.

Prototype Pollution in @hapi/hoek