NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
HIGH severity

CVE-2018-3728 — hoek

HIGHFix: hapijs/hoek@32ed5c9

CVE-2018-3728 is a high-severity (CVSS 8.8) CWE-471 vulnerability in hoek. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for hoek — see the affected versions and patch details below.

Prototype Pollution in hoek

Also known asGHSA-jp4x-w63m-7wgm
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
2 known
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
4.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs91th percentile — riskier than 91% of all scored CVEsHighest risk
0.89%2.29%3.69%5.10%1.7%4.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, a proxy for how much of the ecosystem is exposed.

hoeknpm
3.4Mdownloads / week

Description

Versions of hoek prior to 4.2.1 and 5.0.3 are vulnerable to prototype pollution.

The merge function, and the applyToDefaults and applyToDefaultsWithShallow functions which leverage merge behind the scenes, are vulnerable to a prototype pollution attack when provided an unvalidated payload created from a JSON string containing the __proto__ property.

This can be demonstrated like so:

var Hoek = require('hoek');
var malicious_payload = '{"__proto__":{"oops":"It works !"}}';

var a = {};
console.log("Before : " + a.oops);
Hoek.merge({}, JSON.parse(malicious_payload));
console.log("After : " + a.oops);

This type of attack can be used to overwrite existing properties causing a potential denial of service.

Recommendation

Update to version 4.2.1, 5.0.3 or later.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
📦npmhoek≥ 5.0.0&&< 5.0.35.0.3npm install hoek@5.0.3
📦npmhoekall versions4.2.1npm install hoek@4.2.1

Affected Products

1 product · 2 configurations
Application
hoekhapijs
≥ 5.0.0 && < 5.0.3
range
Exploits & PoCs
2

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for hoek, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update hoek to 5.0.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-3728 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatLow

Red Hat Quay includes hoek as a dependency of protractor which is only used at build time. The vulnerable library is not used at runtime meaning this has a low impact on Red Hat Quay.

ProductFixed inAdvisory
Red Hat Mobile Application Platform 4.6fh-system-dump-tool-0:1.0.0-5.el7RHSA-2018:1263
Red Hat Mobile Application Platform 4.6rhmap46/fh-aaa:1.1.3-4RHSA-2018:1264
Red Hat Quay 3quay/quay-rhel8:v3.6.0-62RHSA-2021:3917

Frequently Asked Questions

Versions of `hoek` prior to 4.2.1 and 5.0.3 are vulnerable to prototype pollution. The `merge` function, and the `applyToDefaults` and `applyToDefaultsWithShallow` functions which leverage `merge` behind the scenes, are vulnerable to a prototype pollution attack when provided an _unvalidated_ payload created from a JSON string containing the `__proto__` property. This can be demonstrated like so: ```javascript var Hoek = require('hoek'); var malicious_payload = '{"__proto__":{"oops":"It works !"}}'; var a = {}; console.log("Before : " + a.oops); Hoek.merge({}, JSON.parse(malicious_payload)
O3 Security · Impact-Aware SCA

Is CVE-2018-3728 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2018-3728: hoek DoS — Fixed in 5.0.3