CVE-2020-27852 — gravityforms
MEDIUMCVE-2020-27852 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in wp-premium/gravityforms. A fix is available for wp-premium/gravityforms — see the affected versions and patch details below.
Gravity Forms stored Cross-Site Scripting (XSS) vulnerability in the survey feature
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
wp-premium/gravityformsReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
A stored Cross-Site Scripting (XSS) vulnerability in the survey feature in Rocketgenius Gravity Forms before 2.4.21 allows remote attackers to inject arbitrary web script or HTML via a textarea field. This code is interpreted by users in a privileged role (Administrator, Editor, etc.).
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | wp-premium/gravityforms | ≥ 2.4&&< 2.4.21 | 2.4.21composer require wp-premium/gravityforms:^2.4.21 |
Affected Products
gravityformsrocketgeniusDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for wp-premium/gravityforms, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update wp-premium/gravityforms to 2.4.21 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-27852 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2020-27852 in your dependencies?
Find it across Packagist, including transitive dependencies.