NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
HIGH severity

CVE-2020-13764 — gravityforms

HIGH

CVE-2020-13764 is a high-severity (CVSS 7.5) Information Exposure vulnerability in wp-premium/gravityforms. A fix is available for wp-premium/gravityforms — see the affected versions and patch details below.

Gravity Forms plugin leak hashed passwords

Also known asGHSA-m983-q76g-cwpq
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs79th percentile — riskier than 79% of all scored CVEsHighest risk
0.42%1.06%1.69%2.33%0.9%1.8%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘wp-premium/gravityforms

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

common.php in the Gravity Forms plugin before 2.4.9 for WordPress can leak hashed passwords because user_pass is not considered a special case for a $current_user->get($property) call.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistwp-premium/gravityformsall versions2.4.9composer require wp-premium/gravityforms:^2.4.9

Affected Products

1 product · 1 configurations
Application
gravityformsrocketgenius
< 2.4.9
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for wp-premium/gravityforms, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update wp-premium/gravityforms to 2.4.9 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-13764 is resolved across your whole dependency graph.

  3. Workarounds

    Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.

Frequently Asked Questions

common.php in the Gravity Forms plugin before 2.4.9 for WordPress can leak hashed passwords because user_pass is not considered a special case for a $current_user->get($property) call.
O3 Security · Impact-Aware SCA

Is CVE-2020-13764 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2020-13764: gravityforms — Fixed in 2.4.9