NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2020-27850 — gravityforms

MEDIUM

CVE-2020-27850 is a medium-severity (CVSS 4.8) Cross-site Scripting (XSS) vulnerability in wp-premium/gravityforms. A fix is available for wp-premium/gravityforms — see the affected versions and patch details below.

Gravity Forms stored Cross-Site Scripting (XSS) vulnerability

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs57th percentile — riskier than 57% of all scored CVEsHighest risk
0.00%0.44%0.87%1.31%0.2%0.8%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘wp-premium/gravityforms

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

A stored Cross-Site Scripting (XSS) vulnerability in forms import feature in Rocketgenius Gravity Forms before 2.4.21 allows remote attackers to inject arbitrary web script or HTML via the import of a GF form. This code is interpreted by users in a privileged role (Administrator, Editor, etc.).

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistwp-premium/gravityforms≥ 2.4&&< 2.4.212.4.21composer require wp-premium/gravityforms:^2.4.21

Affected Products

1 product · 1 configurations
Application
gravityformsrocketgenius
< 2.4.21
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for wp-premium/gravityforms, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update wp-premium/gravityforms to 2.4.21 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-27850 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

A stored Cross-Site Scripting (XSS) vulnerability in forms import feature in Rocketgenius Gravity Forms before 2.4.21 allows remote attackers to inject arbitrary web script or HTML via the import of a GF form. This code is interpreted by users in a privileged role (Administrator, Editor, etc.).
O3 Security · Impact-Aware SCA

Is CVE-2020-27850 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2020-27850: gravityforms XSS — Fixed in 2.4.21