CVE-2020-27218 — jetty-server
MEDIUMCVE-2020-27218 is a medium-severity (CVSS 4.8) CWE-226 vulnerability in org.eclipse.jetty:jetty-server. 7 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for org.eclipse.jetty:jetty-server — see the affected versions and patch details below.
Buffer not correctly recycled in Gzip Request inflation
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.eclipse.jetty:jetty-serverReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Impact
If GZIP request body inflation is enabled and requests from different clients are multiplexed onto a single connection and if an attacker can send a request with a body that is received entirely by not consumed by the application, then a subsequent request on the same connection will see that body prepended to it's body.
The attacker will not see any data, but may inject data into the body of the subsequent request
CVE score is 4.8 AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:L
Workarounds
The problem can be worked around by either:
- Disabling compressed request body inflation by GzipHandler.
- By always fully consuming the request content before sending a response.
- By adding a
Connection: closeto any response where the servlet does not fully consume request content.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.eclipse.jetty:jetty-server | ≥ 9.4.0&&< 9.4.35.v20201120 | 9.4.35.v20201120org.eclipse.jetty:jetty-server:9.4.35.v20201120 |
Affected Products
kafkaapachesparkapachedebian linuxdebianjettyeclipseoncommand system managernetappsnap creator frameworknetappResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
In Eclipse Jetty version 9.4.0.RC0 to 9.4.34.v20201102, 10.0.0.alpha0 to…
Report on lists.apache.org
Report on lists.apache.org
Report on lists.apache.org
Report on lists.apache.org
Report on lists.apache.org
Report on lists.apache.org
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.eclipse.jetty:jetty-server, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.eclipse.jetty:jetty-server to 9.4.35.v20201120 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-27218 is resolved across your whole dependency graph.
Workarounds
Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
In OpenShift Container Platform (OCP), the Hive/Presto/Hadoop components that comprise the OCP Metering stack, ship the vulnerable version of jetty. Since the release of OCP 4.6, the Metering product has been deprecated [1], hence the affected components are marked as wontfix. This may be fixed in the future. [1]…
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat AMQ 7.8.1 | see advisory | RHSA-2021:0417 |
| Red Hat AMQ LTS 7.4.6 | jetty | RHSA-2021:0329 |
| Red Hat Fuse 7.10 | jetty | RHSA-2021:5134 |
| Red Hat Integration Camel Quarkus 2 | see advisory | RHSA-2021:4767 |
| Red Hat Migration Toolkit for Containers 1.4 | rhmtc/openshift-migration-controller-rhel8:v1.4.6-4 | RHBA-2021:2854 |
| Red Hat OpenShift Container Platform 3.11 | jenkins-0:2.289.1.1624365627-1.el7 | RHSA-2021:2517 |
| Red Hat OpenShift Container Platform 4.5 | jenkins-0:2.277.3.1623846768-1.el7 | RHSA-2021:2431 |
| Red Hat OpenShift Container Platform 4.6 | jenkins-0:2.277.3.1623853726-1.el8 | RHSA-2021:2499 |
Frequently Asked Questions
Is CVE-2020-27218 in your dependencies?
Find it across Maven, including transitive dependencies.