CVE-2024-8184 is a medium-severity (CVSS 5.9) Uncontrolled Resource Consumption vulnerability in org.eclipse.jetty:jetty-server. A fix is available for org.eclipse.jetty:jetty-server — see the affected versions and patch details below.
Jetty ThreadLimitHandler.getRemote() vulnerable to remote DoS attacks
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-8184.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.eclipse.jetty:jetty-server☕org.eclipse.jetty:jetty-server☕org.eclipse.jetty:jetty-server☕org.eclipse.jetty:jetty-serverReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Impact
Remote DOS attack can cause out of memory
Description
There exists a security vulnerability in Jetty's ThreadLimitHandler.getRemote() which
can be exploited by unauthorized users to cause remote denial-of-service (DoS) attack. By
repeatedly sending crafted requests, attackers can trigger OutofMemory errors and exhaust the
server's memory.
Affected Versions
- Jetty 12.0.0-12.0.8 (Supported)
- Jetty 11.0.0-11.0.23 (EOL)
- Jetty 10.0.0-10.0.23 (EOL)
- Jetty 9.3.12-9.4.55 (EOL)
Patched Versions
- Jetty 12.0.9
- Jetty 11.0.24
- Jetty 10.0.24
- Jetty 9.4.56
Workarounds
Do not use ThreadLimitHandler.
Consider use of QoSHandler instead to artificially limit resource utilization.
References
Jetty 12 - https://github.com/jetty/jetty.project/pull/11723
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.eclipse.jetty:jetty-server | ≥ 12.0.0&&< 12.0.9 | 12.0.9org.eclipse.jetty:jetty-server:12.0.9 |
| ☕Maven | org.eclipse.jetty:jetty-server | ≥ 10.0.0&&< 10.0.24 | 10.0.24org.eclipse.jetty:jetty-server:10.0.24 |
| ☕Maven | org.eclipse.jetty:jetty-server | ≥ 11.0.0&&< 11.0.24 | 11.0.24org.eclipse.jetty:jetty-server:11.0.24 |
| ☕Maven | org.eclipse.jetty:jetty-server | ≥ 9.3.12&&< 9.4.56 | 9.4.56org.eclipse.jetty:jetty-server:9.4.56 |
Affected Products
jettyeclipseDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.eclipse.jetty:jetty-server, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.eclipse.jetty:jetty-server to 12.0.9 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-8184 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
This vulnerability is rated as moderate rather than important because it requires specific conditions to be met, including continuous, crafted requests that deliberately target memory allocation to exhaust resources. While it can cause a denial of service, it does not lead to direct compromise of sensitive data,…
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.Source: Red Hat security advisory for CVE-2024-8184 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| HawtIO 4.0.0 for Red Hat build of Apache Camel 4 | jetty-server | RHSA-2024:11023 |
| Streams for Apache Kafka 2.8.0 | jetty-server | RHSA-2024:9571 |
| Streams for Apache Kafka 2.9.0 | jetty-server | RHSA-2025:2416 |
Frequently Asked Questions
Is CVE-2024-8184 in your dependencies?
Find it across Maven, including transitive dependencies.