CVE-2026-1605 — jetty-server
HIGHCVE-2026-1605 is a high-severity (CVSS 7.5) Uncontrolled Resource Consumption vulnerability in org.eclipse.jetty:jetty-server. A fix is available for org.eclipse.jetty:jetty-server — see the affected versions and patch details below.
The Eclipse Jetty Server Artifact has a Gzip request memory leak
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-1605.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.eclipse.jetty:jetty-server☕org.eclipse.jetty:jetty-serverReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Description (as reported)
There is a memory leak when using GzipHandler in jetty-12.0.30 that can cause off-heap OOMs. This can be used for DoS attacks so I'm reporting this as a vulnerability.
The leak is created by requests where the request is inflated (Content-Encoding: gzip) and the response is not deflated (no Accept-Encoding: gzip). In these conditions, a new inflator will be created by GzipRequest and never released back into GzipRequest.__inflaterPool because gzipRequest.destory() is not called.
In heap dumps one can see thousands of java.util.zip.Inflator objects, which use both Java heaps and native memory. Leaking native memory causes of off-heap OOMs.
Code path in GzipHandler.handle():
- Line 601:
GzipRequestis created when request inflation is needed. - Lines 611-616: The callback is only wrapped in
GzipResponseAndCallbackwhen both inflation and deflation are needed. - Lines 619-625: If the handler accepts the request (returns true),
gzipRequest.destroy()is only called in the "request not accepted" path (returns false)
When deflation is needed, GzipResponseAndCallback (lines 102 and 116) properly calls gzipRequest.destroy() in its succeeded() and failed() methods. But this wrapper is only created when deflation is needed.
Possible fix:
The callback should be wrapped whenever a GzipRequest is created, not just when deflation is needed. This ensures gzipRequest.destroy() is always called when the request completes.
Impact
The leak causes the JVM to crash with OOME.
Patches
No patches yet.
Workarounds
Disable GzipHandler.
References
https://github.com/jetty/jetty.project/issues/14260
https://gitlab.eclipse.org/security/cve-assignment/-/issues/79
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.eclipse.jetty:jetty-server | ≥ 12.1.0&&< 12.1.6 | 12.1.6org.eclipse.jetty:jetty-server:12.1.6 |
| ☕Maven | org.eclipse.jetty:jetty-server | ≥ 12.0.0&&< 12.0.32 | 12.0.32org.eclipse.jetty:jetty-server:12.0.32 |
Affected Products
jettyeclipseDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.eclipse.jetty:jetty-server, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.eclipse.jetty:jetty-server to 12.1.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-1605 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
This Important flaw in Eclipse Jetty's GzipHandler can lead to a denial of service in affected Red Hat products. The vulnerability arises when compressed HTTP requests are processed without a corresponding compressed response, causing a resource leak that can exhaust system resources and render the service unavailable.
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base, or stability.Source: Red Hat security advisory for CVE-2026-1605 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| HawtIO HawtIO 4.4.0 | jetty-server | RHSA-2026:25089 |
| Red Hat AMQ Broker 7.14.0 | jetty-server | RHSA-2026:8509 |
| Red Hat JBoss Enterprise Application Platform 8.1.6 | org.jboss.activemq.artemis.integration/artemis-wildfly-integration:2.0.3.Final-redhat-00001 | RHSA-2026:25126 |
| Red Hat JBoss Enterprise Application Platform 8.1 for RHEL 8 | eap8-activemq-artemis-0:2.40.0-7.redhat_00015.1.el8eap | RHSA-2026:25125 |
| OpenShift Developer Tools and Services 4.12 | ocp-tools-4/jenkins-rhel8:1786628667 | RHSA-2026:60247 |
| OpenShift Developer Tools and Services 4.13 | ocp-tools-4/jenkins-rhel8:1786628681 | RHSA-2026:60249 |
| OpenShift Developer Tools and Services 4.14 | ocp-tools-4/jenkins-rhel8:1786533561 | RHSA-2026:60248 |
| OpenShift Developer Tools and Services 4.15 | ocp-tools-4/jenkins-rhel8:1786533565 | RHSA-2026:60239 |
Frequently Asked Questions
Is CVE-2026-1605 in your dependencies?
Find it across Maven, including transitive dependencies.