CVE-2020-13935 is a high-severity (CVSS 7.5) CWE-835 vulnerability in org.apache.tomcat:tomcat. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for org.apache.tomcat:tomcat — see the affected versions and patch details below.
Infinite Loop in Apache Tomcat
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2020-13935.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.tomcat:tomcat☕org.apache.tomcat:tomcat☕org.apache.tomcat:tomcat☕org.apache.tomcat:tomcat☕org.apache.tomcat.embed:tomcat-embed-websocket☕org.apache.tomcat.embed:tomcat-embed-websocket☕org.apache.tomcat.embed:tomcat-embed-websocket☕org.apache.tomcat.embed:tomcat-embed-websocket+4 moreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
The payload length in a WebSocket frame was not correctly validated in Apache Tomcat 10.0.0-M1 to 10.0.0-M6, 9.0.0.M1 to 9.0.36, 8.5.0 to 8.5.56 and 7.0.27 to 7.0.104. Invalid payload lengths could trigger an infinite loop. Multiple requests with invalid payload lengths could lead to a denial of service.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.tomcat:tomcat | ≥ 10.0.0-M1&&< 10.0.0-M7 | 10.0.0-M7org.apache.tomcat:tomcat:10.0.0-M7 |
| ☕Maven | org.apache.tomcat:tomcat | ≥ 9.0.0.M1&&< 9.0.37 | 9.0.37org.apache.tomcat:tomcat:9.0.37 |
| ☕Maven | org.apache.tomcat:tomcat | ≥ 8.5.0&&< 8.5.57 | 8.5.57org.apache.tomcat:tomcat:8.5.57 |
| ☕Maven | org.apache.tomcat:tomcat | ≥ 7.0.27&&< 7.0.105 | 7.0.105org.apache.tomcat:tomcat:7.0.105 |
| ☕Maven | org.apache.tomcat.embed:tomcat-embed-websocket | ≥ 7.0.27&&< 7.0.105 | 7.0.105org.apache.tomcat.embed:tomcat-embed-websocket:7.0.105 |
| ☕Maven | org.apache.tomcat.embed:tomcat-embed-websocket | ≥ 8.5.0&&< 8.5.57 | 8.5.57org.apache.tomcat.embed:tomcat-embed-websocket:8.5.57 |
Affected Products
tomcatapacheubuntu linuxcanonicaldebian linuxdebianepolicy orchestratormcafeeoncommand system managernetappleapopensuseResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.tomcat:tomcat, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.tomcat:tomcat to 10.0.0-M7 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-13935 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Red Hat Certificate System 10.0 as well as Red Hat Enterprise Linux 8's Identity Management, are using a vulnerable version of Tomcat, bundled into the pki-servlet-engine component. However, there is no entry point for WebSockets, thus it is not possible to trigger the flaw in a supported setup. A future update may…
Red Hat has investigated whether a possible mitigation exists for this issue, and has not been able to identify a practical example. Please update as soon as possible.Source: Red Hat security advisory for CVE-2020-13935 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| EAP 6.4.24 release | see advisory | RHSA-2022:5458 |
| Red Hat Enterprise Linux 7 | tomcat-0:7.0.76-15.el7 | RHSA-2020:4004 |
| Red Hat Fuse 7.9 | tomcat | RHSA-2021:3140 |
| Red Hat JBoss Enterprise Application Platform 6.4 async | jbossweb | RHSA-2020:3382 |
| Red Hat JBoss Enterprise Application Platform 6.4 for RHEL 5 | jbossweb-0:7.5.31-2.Final_redhat_2.1.ep6.el5 | RHSA-2020:3383 |
| Red Hat JBoss Enterprise Application Platform 6.4 for RHEL 6 | jboss-as-appclient-0:7.5.24-2.Final_redhat_00001.1.ep6.el6 | RHSA-2022:5459 |
| Red Hat JBoss Enterprise Application Platform 6.4 for RHEL 7 | jboss-as-appclient-0:7.5.24-2.Final_redhat_00001.1.ep6.el7 | RHSA-2022:5460 |
| Red Hat JBoss Web Server 3.1 | tomcat | RHSA-2020:3305 |
Frequently Asked Questions
Is CVE-2020-13935 in your dependencies?
Find it across Maven, including transitive dependencies.