CVE-2019-16107 — phpbb
MEDIUMCVE-2019-16107 is a medium-severity (CVSS 4.3) Cross-Site Request Forgery (CSRF) vulnerability in phpbb/phpbb. A fix is available for phpbb/phpbb — see the affected versions and patch details below.
phpBB Cross-Site Request Forgery (CSRF)
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
phpbb/phpbbReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Missing form token validation in phpBB 3.2.7 allows CSRF in deleting post attachments.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | phpbb/phpbb | ≥ 3.2.7&&< 3.2.8 | 3.2.8composer require phpbb/phpbb:^3.2.8 |
Affected Products
phpbbphpbbDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for phpbb/phpbb, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update phpbb/phpbb to 3.2.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-16107 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2019-16107 in your dependencies?
Find it across Packagist, including transitive dependencies.