CVE-2019-14853 — ecdsa
HIGHCVE-2019-14853 is a high-severity (CVSS 7.5) CWE-391 vulnerability in ecdsa. A fix is available for ecdsa — see the affected versions and patch details below.
Duplicate Advisory: possible DoS caused by malformed signature decoding in Pure-Python ECDSA
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
ecdsaReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
An error-handling flaw was found in python-ecdsa before version 0.13.3. During signature decoding, malformed DER signatures could raise unexpected exceptions (or no exceptions at all), which could lead to a denial of service.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | ecdsa | all versions | 0.13.3pip install --upgrade 'ecdsa==0.13.3' |
Affected Products
python-ecdsapython-ecdsa_projectDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ecdsa, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update ecdsa to 0.13.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-14853 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Although Red Hat OpenStack Platform ships the flawed code, RHOSP does not actually use python-ecdsa's functionality. As such, Red Hat OpenStack Platform will not be providing a fix for python-ecdsa at this time. Current releases of Red Hat Virtualization Manager no longer includes python-ecdsa as a dependency. While…
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Satellite 6.10 for RHEL 7 | python-ecdsa-0:0.13.3-2.el7pc | RHSA-2021:4702 |
Frequently Asked Questions
Is CVE-2019-14853 in your dependencies?
Find it across PyPI, including transitive dependencies.