CVE-2016-10526 is a high-severity (CVSS 8.6) CWE-391 vulnerability in grunt-gh-pages. A fix is available for grunt-gh-pages — see the affected versions and patch details below.
grunt-gh-pages before 0.10.0 may allow unencrypted GitHub credentials to be written to a log file
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
grunt-gh-pagesnpmDescription
A common setup to deploy to gh-pages on every commit via a CI system is to expose a github token to ENV and to use it directly in the auth part of the url. In module versions < 0.9.1 the auth portion of the url is outputted as part of the grunt tasks logging function. If this output is publicly available then the credentials should be considered compromised.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | grunt-gh-pages | all versions | 0.10.0npm install grunt-gh-pages@0.10.0 |
Affected Products
grunt-gh-pagesgrunt-gh-pages_projectDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for grunt-gh-pages, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update grunt-gh-pages to 0.10.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-10526 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2016-10526 in your dependencies?
Find it across npm, including transitive dependencies.