NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦 npm
Not in CISA KEV

grunt-gh-pages before 0.10.0 may allow unencrypted GitHub credentials to be written to a log fileGHSA-rrj3-qmh8-72pf

Fix: tschaub/grunt-gh-pages#41

GHSA-rrj3-qmh8-72pf is a CWE-391 vulnerability in grunt-gh-pages. A fix is available for grunt-gh-pages — see the affected versions and patch details below.

Also known asCVE-2016-10526
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 28, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.6%probability of exploitation in next 30 days
Lower Risk-0.03%
Lower risk than most CVEs76th percentile — riskier than 76% of all scored CVEsHighest risk
0.00%0.71%1.42%2.14%0.3%1.6%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

9other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
grunt-gh-pagesnpm
6Kdownloads / week

Description

Versions of grunt-gh-pages prior to 0.10.0 are affected by a vulnerability which may cause unencrypted GitHub credentials to be written to a log file in certain circumstances.

In the grunt-gh-pages deployment scenario where authentication is performed by injecting a GitHub token directly into the auth portion of the URL, grunt-gh-pages will write the token to a log file, unencrypted.

Recommendation

Update to version 0.10.0 or later.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmgrunt-gh-pagesall versions0.10.0npm install grunt-gh-pages@0.10.0

Affected Products

1 product · 1 configurations
Application
grunt-gh-pagesgrunt-gh-pages_project
< 0.9.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for grunt-gh-pages, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update grunt-gh-pages to 0.10.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-rrj3-qmh8-72pf is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Versions of `grunt-gh-pages` prior to 0.10.0 are affected by a vulnerability which may cause unencrypted GitHub credentials to be written to a log file in certain circumstances. In the `grunt-gh-pages` deployment scenario where authentication is performed by injecting a GitHub token directly into the auth portion of the URL, `grunt-gh-pages` will write the token to a log file, unencrypted. ## Recommendation Update to version 0.10.0 or later.
O3 Security · Impact-Aware SCA

Is GHSA-rrj3-qmh8-72pf in your dependencies?

Find it across npm, including transitive dependencies.

grunt-gh-pages before 0.10.0 may allow unencrypted…