NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
CRITICAL severity

CVE-2019-14859 — ecdsa

CRITICALFix: warner/python-ecdsa#115

CVE-2019-14859 is a critical-severity (CVSS 9.1) CWE-347 vulnerability in ecdsa. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for ecdsa — see the affected versions and patch details below.

Improper Verification of Cryptographic Signature in Pure-Python ECDSA

Also known asGHSA-8qxj-f9rh-9fg2PYSEC-2020-163
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
2 known
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs75th percentile — riskier than 75% of all scored CVEsHighest risk
0.00%0.70%1.40%2.10%0.1%1.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍ecdsa

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

A flaw was found in all python-ecdsa versions before 0.13.3, where it did not correctly verify whether signatures used DER encoding. Without this verification, a malformed signature could be accepted, making the signature malleable. Without proper verification, an attacker could use a malleable signature to create false transactions.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIecdsaall versions0.13.3pip install --upgrade 'ecdsa==0.13.3'

Affected Products

4 products · 8 configurations
Application
python-ecdsapython-ecdsa_project
< 0.13.3
range
Application
ceph storageredhat
2 versions
2.03.0
Application
openstackredhat
4 versions
10131415
Application
virtualizationredhat
1 version
4.0
Exploits & PoCs
2

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ecdsa, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update ecdsa to 0.13.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-14859 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate

Although Red Hat OpenStack Platform ships the flawed code, RHOSP does not actually use python-ecdsa's functionality. As such, Red Hat OpenStack Platform will not be providing a fix for python-ecdsa at this time. Red Hat CloudForms 5.9, 5.10 and 5.11 is not affected as these versions no longer ship the python-ecdsa…

ProductFixed inAdvisory
Red Hat Satellite 6.10 for RHEL 7python-ecdsa-0:0.13.3-2.el7pcRHSA-2021:4702

Frequently Asked Questions

A flaw was found in all python-ecdsa versions before 0.13.3, where it did not correctly verify whether signatures used DER encoding. Without this verification, a malformed signature could be accepted, making the signature malleable. Without proper verification, an attacker could use a malleable signature to create false transactions.
O3 Security · Impact-Aware SCA

Is CVE-2019-14859 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2019-14859: ecdsa — Fixed in 0.13.3