NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

CVE-2018-16859 — ansible

MEDIUMFix: ansible/ansible#49142

CVE-2018-16859 is a medium-severity (CVSS 4.4) CWE-532 vulnerability in ansible. A fix is available for ansible — see the affected versions and patch details below.

Ansible Logs Passwords If PowerShell ScriptBlock is Enabled

Also known asGHSA-v735-2pp6-h86rPYSEC-2018-60
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs46th percentile — riskier than 46% of all scored CVEsHighest risk
0.00%0.35%0.69%1.04%0.1%0.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
🐍ansible🐍ansible🐍ansible

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Execution of Ansible playbooks on Windows platforms with PowerShell ScriptBlock logging and Module logging enabled can allow for 'become' passwords to appear in EventLogs in plaintext. A local user with administrator privileges on the machine can view these logs and discover the plaintext password. Ansible Engine 2.8 and older are believed to be vulnerable.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIansible≥ 2.7.0a1&&< 2.7.32.7.3pip install --upgrade 'ansible==2.7.3'
🐍PyPIansibleall versions2.5.12pip install --upgrade 'ansible==2.5.12'
🐍PyPIansible≥ 2.6.0a1&&< 2.6.92.6.9pip install --upgrade 'ansible==2.6.9'

Affected Products

1 product · 4 configurations
Application
ansible engineredhat
≥ 2.7.5 && ≤ 2.8
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ansible, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update ansible to 2.7.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-16859 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate

CloudForms and Satellite 6 are not affected by this issue, since Microsoft Windows is not a supported platform.

ProductFixed inAdvisory
Red Hat Ansible Engine 2.5 for RHEL 7ansible-0:2.5.13-1.el7aeRHSA-2018:3770
Red Hat Ansible Engine 2.6 for RHEL 7ansible-0:2.6.10-1.el7aeRHSA-2018:3771
Red Hat Ansible Engine 2.7 for RHEL 7ansible-0:2.7.4-1.el7aeRHSA-2018:3773
Red Hat Ansible Engine 2 for RHEL 7ansible-0:2.7.4-1.el7aeRHSA-2018:3772

Frequently Asked Questions

Execution of Ansible playbooks on Windows platforms with PowerShell ScriptBlock logging and Module logging enabled can allow for 'become' passwords to appear in EventLogs in plaintext. A local user with administrator privileges on the machine can view these logs and discover the plaintext password. Ansible Engine 2.8 and older are believed to be vulnerable.
O3 Security · Impact-Aware SCA

Is CVE-2018-16859 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2018-16859: ansible — Fixed in 2.7.3