NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

CVE-2017-7675 — tomcat

HIGHFix: apache/tomcat@cf181ed

CVE-2017-7675 is a high-severity (CVSS 7.5) Path Traversal vulnerability in org.apache.tomcat:tomcat. EPSS puts its 30-day exploitation probability at 10.1% (96th percentile). A fix is available for org.apache.tomcat:tomcat — see the affected versions and patch details below.

Improper Limitation of a Pathname to a Restricted Directory in Apache Tomcat

Also known asGHSA-68g5-8q7f-m384
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
10.1%probability of exploitation in next 30 days
Moderate Risk0.00%
Lower risk than most CVEs96th percentile — riskier than 96% of all scored CVEsHighest risk
1.78%5.21%8.64%12.1%3.7%10.1%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
☕org.apache.tomcat:tomcat☕org.apache.tomcat:tomcat

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

The HTTP/2 implementation in Apache Tomcat 9.0.0.M1 to 9.0.0.M21 and 8.5.0 to 8.5.15 bypassed a number of security checks that prevented directory traversal attacks. It was therefore possible to bypass security constraints using a specially crafted URL.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.tomcat:tomcat≥ 9.0.0.M1&&< 9.0.0.M229.0.0.M22org.apache.tomcat:tomcat:9.0.0.M22
☕Mavenorg.apache.tomcat:tomcat≥ 8.5.0&&< 8.5.168.5.16org.apache.tomcat:tomcat:8.5.16

Affected Products

1 product · 37 configurations
Application
tomcatapache
17 versions
8.5.08.5.18.5.28.5.38.5.48.5.58.5.68.5.78.5.88.5.98.5.108.5.11

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.tomcat:tomcat, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.tomcat:tomcat to 9.0.0.M22 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-7675 is resolved across your whole dependency graph.

  3. Workarounds

    Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.

Frequently Asked Questions

The HTTP/2 implementation in Apache Tomcat 9.0.0.M1 to 9.0.0.M21 and 8.5.0 to 8.5.15 bypassed a number of security checks that prevented directory traversal attacks. It was therefore possible to bypass security constraints using a specially crafted URL.
O3 Security · Impact-Aware SCA

Is CVE-2017-7675 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2017-7675: tomcat Path Traversal — Fixed in 9.0.0.M22