NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

CVE-2017-7466 — ansible

HIGHFix: ansible/ansible@0d41878

CVE-2017-7466 is a high-severity (CVSS 8) Improper Input Validation vulnerability in ansible. A fix is available for ansible — see the affected versions and patch details below.

Ansible Arbitrary Code Execution

Also known asGHSA-3m8p-xpm6-8ww3PYSEC-2018-40
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
3.0%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs88th percentile — riskier than 88% of all scored CVEsHighest risk
2.16%2.71%3.26%3.81%3.3%3.0%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍ansible

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Ansible before version 2.3 has an input validation vulnerability in the handling of data sent from client systems. An attacker with control over a client system being managed by Ansible, and the ability to send facts back to the Ansible server, could use this flaw to execute arbitrary code on the Ansible server using the Ansible server privileges.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIansibleall versions2.2.3.0pip install --upgrade 'ansible==2.2.3.0'

Affected Products

2 products · 3 configurations
Application
ansibleredhat
< 2.3
range
Application
openstackredhat
2 versions
1011

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ansible, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update ansible to 2.2.3.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-7466 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant
ProductFixed inAdvisory
Red Hat Gluster Storage 3.2 for RHEL 7ansible-0:2.2.3.0-1.el7RHSA-2017:1334
Red Hat OpenShift Container Platform 3.2ansible-0:2.2.3.0-1.el7RHSA-2017:1244
Red Hat OpenStack Platform 10.0 (Newton)ansible-0:2.2.3.0-1.el7RHSA-2017:1599
Red Hat OpenStack Platform 11.0 (Ocata)ansible-0:2.2.3.0-1.el7RHSA-2017:1476
Red Hat Storage Console 2 for Red Hat Enteprise Linux 7ansible-0:2.2.3.0-1.el7RHSA-2017:1499
Red Hat Virtualization Engine 4.1ansible-0:2.3.0.0-4.el7RHSA-2017:1685

Frequently Asked Questions

Ansible before version 2.3 has an input validation vulnerability in the handling of data sent from client systems. An attacker with control over a client system being managed by Ansible, and the ability to send facts back to the Ansible server, could use this flaw to execute arbitrary code on the Ansible server using the Ansible server privileges.
O3 Security · Impact-Aware SCA

Is CVE-2017-7466 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2017-7466: ansible RCE — Fixed in 2.2.3.0