NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2017-1000431 — ezpublish-legacy

MEDIUMFix: ezsystems/ezpublish-legacy@c717429

CVE-2017-1000431 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in ezsystems/ezpublish-legacy. A fix is available for ezsystems/ezpublish-legacy — see the affected versions and patch details below.

eZ Publish Cross-site Scripting (XSS) vulnerability

Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Oct 30, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs52th percentile — riskier than 52% of all scored CVEsHighest risk
0.00%0.39%0.79%1.18%0.3%0.7%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
🐘ezsystems/ezpublish-legacy🐘ezsystems/ezpublish-legacy

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

eZ Systems eZ Publish version 5.4.0 to 5.4.9, and 5.3.12.0 and older, is vulnerable to an XSS issue in the search module, resulting in a risk of attackers injecting scripts which may e.g. steal authentication credentials.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistezsystems/ezpublish-legacy≥ 5.4.0&&< 5.4.105.4.10composer require ezsystems/ezpublish-legacy:^5.4.10
🐘Packagistezsystems/ezpublish-legacy≥ 5.3.0&&< 5.3.12.15.3.12.1composer require ezsystems/ezpublish-legacy:^5.3.12.1

Affected Products

1 product · 2 configurations
Application
ez publishez
≥ 5.4.0 && ≤ 5.3.12
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ezsystems/ezpublish-legacy, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update ezsystems/ezpublish-legacy to 5.4.10 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-1000431 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

eZ Systems eZ Publish version 5.4.0 to 5.4.9, and 5.3.12.0 and older, is vulnerable to an XSS issue in the search module, resulting in a risk of attackers injecting scripts which may e.g. steal authentication credentials.
O3 Security · Impact-Aware SCA

Is CVE-2017-1000431 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2017-1000431: ezpublish-legacy XSS — Fixed in 5.4.10