CVE-2017-0902 is a high-severity (CVSS 8.1) CWE-350 vulnerability in rubygems-update. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for rubygems-update — see the affected versions and patch details below.
RubyGems has Origin Validation Error vulnerability
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
rubygems-updateReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.
Description
RubyGems version 2.6.12 and earlier is vulnerable to a DNS hijacking vulnerability that allows a MITM attacker to force the RubyGems client to download and install gems from a server that the attacker controls.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 💎RubyGems | rubygems-update | all versions | 2.6.13bundle update rubygems-update --conservative |
Affected Products
ubuntu linuxcanonicaldebian linuxdebianenterprise linux desktopredhatenterprise linux serverredhatenterprise linux server ausredhatenterprise linux server eusredhatResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for rubygems-update, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update rubygems-update to 2.6.13 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-0902 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
This issue affects the versions of ruby as shipped with Red Hat Enterprise Linux 6, and 7 and the versions of rh-ruby22-ruby and rh-ruby23-ruby as shipped with Red Hat Software Collections. Red Hat Product Security has rated this issue as having Moderate security impact. A future update may address this issue. For…
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Enterprise Linux 7 | ruby-0:2.0.0.648-33.el7_4 | RHSA-2018:0378 |
| Red Hat Software Collections for Red Hat Enterprise Linux 6 | rh-ruby24-ruby-0:2.4.2-86.el6 | RHSA-2017:3485 |
| Red Hat Software Collections for Red Hat Enterprise Linux 6 | rh-ruby22-ruby-0:2.2.9-19.el6 | RHSA-2018:0583 |
| Red Hat Software Collections for Red Hat Enterprise Linux 6 | rh-ruby23-ruby-0:2.3.6-67.el6 | RHSA-2018:0585 |
Frequently Asked Questions
Is CVE-2017-0902 in your dependencies?
Find it across RubyGems, including transitive dependencies.