NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2016-6347 — resteasy-client

MEDIUM

CVE-2016-6347 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in org.jboss.resteasy:resteasy-client. A fix is available for org.jboss.resteasy:resteasy-client — see the affected versions and patch details below.

Improper Neutralization of Input During Web Page Generation in RESTEasy

Also known asGHSA-r346-rmrg-qpgh
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs79th percentile — riskier than 79% of all scored CVEsHighest risk
0.00%0.80%1.61%2.41%0.1%1.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
☕org.jboss.resteasy:resteasy-client☕org.jboss.resteasy:resteasy-client

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Cross-site scripting (XSS) vulnerability in the default exception handler in RESTEasy allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.jboss.resteasy:resteasy-clientall versions3.0.20.Finalorg.jboss.resteasy:resteasy-client:3.0.20.Final
☕Mavenorg.jboss.resteasy:resteasy-client≥ 3.1.0.Beta1&&< 3.1.0.CR13.1.0.CR1org.jboss.resteasy:resteasy-client:3.1.0.CR1

Affected Products

1 product · 1 configurations
Application
resteasyredhat
all

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.jboss.resteasy:resteasy-client, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.jboss.resteasy:resteasy-client to 3.0.20.Final or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-6347 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Cross-site scripting (XSS) vulnerability in the default exception handler in RESTEasy allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
O3 Security · Impact-Aware SCA

Is CVE-2016-6347 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2016-6347: resteasy-client XSS — Fixed in 3.0.20.Final