NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2016-6348 — resteasy-client

MEDIUM

CVE-2016-6348 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in org.jboss.resteasy:resteasy-client. A fix is available for org.jboss.resteasy:resteasy-client — see the affected versions and patch details below.

JacksonJsonpInterceptor susceptible to cross-site script inclusion (XSSI) attack

Also known asGHSA-9xfc-j5mf-9w5p
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs75th percentile — riskier than 75% of all scored CVEsHighest risk
0.00%0.69%1.38%2.07%0.1%1.6%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.jboss.resteasy:resteasy-client

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

JacksonJsonpInterceptor in RESTEasy might allow remote attackers to conduct a cross-site script inclusion (XSSI) attack.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.jboss.resteasy:resteasy-clientall versions3.0.20.Finalorg.jboss.resteasy:resteasy-client:3.0.20.Final

Affected Products

1 product · 1 configurations
Application
resteasyredhat
all

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.jboss.resteasy:resteasy-client, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.jboss.resteasy:resteasy-client to 3.0.20.Final or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-6348 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

UbuntuMEDIUM

Frequently Asked Questions

JacksonJsonpInterceptor in RESTEasy might allow remote attackers to conduct a cross-site script inclusion (XSSI) attack.
O3 Security · Impact-Aware SCA

Is CVE-2016-6348 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2016-6348: resteasy-client — Fixed in 3.0.20.Final