NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕ Maven
Not in CISA KEV

CVE-2014-3490 — resteasy-client

Fix: resteasy/Resteasy#521

CVE-2014-3490 is a security vulnerability in org.jboss.resteasy:resteasy-client. A fix is available for org.jboss.resteasy:resteasy-client — see the affected versions and patch details below.

Incorrect Privilege Assignment in RESTEasy

Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 1, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
4.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs92th percentile — riskier than 92% of all scored CVEsHighest risk
4.07%4.43%4.79%5.15%4.6%4.6%May 26Aug 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

2 pkgs affected
☕org.jboss.resteasy:resteasy-client☕org.jboss.resteasy:resteasy-client

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

RESTEasy 2.3.1 before 2.3.8.SP2 and 3.x before 3.0.9, as used in Red Hat JBoss Enterprise Application Platform (EAP) 6.3.0, does not disable external entities when the resteasy.document.expand.entity.references parameter is set to false, which allows remote attackers to read arbitrary files and have other unspecified impact via unspecified vectors, related to an XML External Entity (XXE) issue. NOTE: this vulnerability exists because of an incomplete fix for CVE-2012-0818.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.jboss.resteasy:resteasy-client≥ 2.3.1&&< 2.3.8.SP22.3.8.SP2org.jboss.resteasy:resteasy-client:2.3.8.SP2
☕Mavenorg.jboss.resteasy:resteasy-client≥ 3.0.0&&< 3.0.9.Final3.0.9.Finalorg.jboss.resteasy:resteasy-client:3.0.9.Final

Affected Products

2 products · 10 configurations
Application
jboss enterprise application platformredhat
1 version
6.3.0
Application
resteasyredhat
≥ 3.0.0 && ≤ 2.3.7.2
1 version
3.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.jboss.resteasy:resteasy-client, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.jboss.resteasy:resteasy-client to 2.3.8.SP2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2014-3490 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
ProductFixed inAdvisory
Red Hat Enterprise Linux 7resteasy-base-0:2.3.5-3.el7_0RHSA-2014:1011
Red Hat JBoss BPMS 6.0resteasyRHSA-2015:0234
Red Hat JBoss BRMS 6.0resteasyRHSA-2015:0235
Red Hat JBoss Data Grid 6.3see advisoryRHSA-2014:1298
Red Hat JBoss Data Virtualization 6.0resteasyRHSA-2015:0765
Red Hat JBoss Data Virtualization 6.1see advisoryRHSA-2015:0675
Red Hat JBoss Enterprise Application Platform 6.3resteasyRHSA-2014:1039
Red Hat JBoss Enterprise Application Platform 6.3 for RHEL 5resteasy-0:2.3.8-5.SP1_redhat_1.1.ep6.el5RHSA-2014:1040

Frequently Asked Questions

RESTEasy 2.3.1 before 2.3.8.SP2 and 3.x before 3.0.9, as used in Red Hat JBoss Enterprise Application Platform (EAP) 6.3.0, does not disable external entities when the resteasy.document.expand.entity.references parameter is set to false, which allows remote attackers to read arbitrary files and have other unspecified impact via unspecified vectors, related to an XML External Entity (XXE) issue. NOTE: this vulnerability exists because of an incomplete fix for CVE-2012-0818.
O3 Security · Impact-Aware SCA

Is CVE-2014-3490 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2014-3490: resteasy-client XXE — Fixed in 2.3.8.SP2