NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2016-0782 — activemq-client

MEDIUMFix: apache/activemq@0c9fdb5

CVE-2016-0782 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in org.apache.activemq:activemq-client. A fix is available for org.apache.activemq:activemq-client — see the affected versions and patch details below.

Improper Neutralization of Input During Web Page Generation in Apache ActiveMQ

Also known asGHSA-8rcq-p4gh-vmj8
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
6.1%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs93th percentile — riskier than 93% of all scored CVEsHighest risk
0.00%2.51%5.03%7.54%1.2%6.1%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
☕org.apache.activemq:activemq-client☕org.apache.activemq:activemq-client☕org.apache.activemq:activemq-client

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

The administration web console in Apache ActiveMQ 5.x before 5.11.4, 5.12.x before 5.12.3, and 5.13.x before 5.13.2 allows remote authenticated users to conduct cross-site scripting (XSS) attacks and consequently obtain sensitive information from a Java memory dump via vectors related to creating a queue.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.activemq:activemq-client≥ 5.0.0&&< 5.11.45.11.4org.apache.activemq:activemq-client:5.11.4
☕Mavenorg.apache.activemq:activemq-client≥ 5.12.0&&< 5.12.35.12.3org.apache.activemq:activemq-client:5.12.3
☕Mavenorg.apache.activemq:activemq-client≥ 5.13.0&&< 5.13.25.13.2org.apache.activemq:activemq-client:5.13.2

Affected Products

1 product · 28 configurations
Application
activemqapache
28 versions
5.1.05.2.05.3.05.3.15.3.25.4.05.4.15.4.25.4.35.5.05.5.15.6.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.activemq:activemq-client, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.activemq:activemq-client to 5.11.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-0782 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Frequently Asked Questions

The administration web console in Apache ActiveMQ 5.x before 5.11.4, 5.12.x before 5.12.3, and 5.13.x before 5.13.2 allows remote authenticated users to conduct cross-site scripting (XSS) attacks and consequently obtain sensitive information from a Java memory dump via vectors related to creating a queue.
O3 Security · Impact-Aware SCA

Is CVE-2016-0782 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2016-0782: activemq-client XSS — Fixed in 5.11.4