CVE-2016-0706 — tomcat
MEDIUMCVE-2016-0706 is a medium-severity (CVSS 4.3) Information Exposure vulnerability in org.apache.tomcat:tomcat. A fix is available for org.apache.tomcat:tomcat — see the affected versions and patch details below.
Exposure of Sensitive Information to an Unauthorized Actor in Apache Tomcat
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2016-0706.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.tomcat:tomcat☕org.apache.tomcat:tomcat☕org.apache.tomcat:tomcatReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Apache Tomcat 6.x before 6.0.45, 7.x before 7.0.68, 8.x before 8.0.31, and 9.x before 9.0.0.M2 does not place org.apache.catalina.manager.StatusManagerServlet on the org/apache/catalina/core/RestrictedServlets.properties list, which allows remote authenticated users to bypass intended SecurityManager restrictions and read arbitrary HTTP requests, and consequently discover session ID values, via a crafted web application.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.tomcat:tomcat | ≥ 9.0.0.M1&&< 9.0.0.M2 | 9.0.0.M2org.apache.tomcat:tomcat:9.0.0.M2 |
| ☕Maven | org.apache.tomcat:tomcat | ≥ 8.0.0.RC1&&< 8.0.31 | 8.0.31org.apache.tomcat:tomcat:8.0.31 |
| ☕Maven | org.apache.tomcat:tomcat | ≥ 6.0.0&&< 6.0.45 | 6.0.45org.apache.tomcat:tomcat:6.0.45 |
Affected Products
tomcatapacheubuntu linuxcanonicaldebian linuxdebianDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.tomcat:tomcat, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.tomcat:tomcat to 9.0.0.M2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-0706 is resolved across your whole dependency graph.
Workarounds
Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Enterprise Linux 6 | tomcat6-0:6.0.24-98.el6_8 | RHSA-2016:2045 |
| Red Hat Enterprise Linux 7 | tomcat-0:7.0.69-10.el7 | RHSA-2016:2599 |
| Red Hat JBoss Enterprise Web Server 2 for RHEL 6 | tomcat7-0:7.0.54-23_patch_05.ep6.el6 | RHSA-2016:2807 |
| Red Hat JBoss Web Server 2.1 | tomcat7 | RHSA-2016:2808 |
| Red Hat JBoss Web Server 3.0 | see advisory | RHSA-2016:1089 |
| Red Hat JBoss Web Server 3 for RHEL 6 | httpd24-0:2.4.6-61.ep7.el6 | RHSA-2016:1087 |
| Red Hat JBoss Web Server 3 for RHEL 7 | httpd24-0:2.4.6-61.ep7.el7 | RHSA-2016:1088 |
Frequently Asked Questions
Is CVE-2016-0706 in your dependencies?
Find it across Maven, including transitive dependencies.