NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
💎
💎 RubyGems
Not in CISA KEV
MEDIUM severity

CVE-2015-7565 — ember-source

MEDIUM

CVE-2015-7565 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in ember-source. A fix is available for ember-source — see the affected versions and patch details below.

ember-source Cross-site Scripting vulnerability

Published
Updated
Affected
6 pkgs
Patched
6 / 6
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs57th percentile — riskier than 57% of all scored CVEsHighest risk
0.00%0.44%0.88%1.32%0.3%0.8%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

6 pkgs affected
💎ember-source💎ember-source💎ember-source💎ember-source💎ember-source💎ember-source

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.

Description

Cross-site scripting (XSS) vulnerability in Ember.js 1.8.x through 1.10.x, 1.11.x before 1.11.4, 1.12.x before 1.12.2, 1.13.x before 1.13.12, 2.0.x before 2.0.3, 2.1.x before 2.1.2, and 2.2.x before 2.2.1 allows remote attackers to inject arbitrary web script or HTML.

Affected Packages

6 total 6 fixed
EcosystemPackageVulnerable rangeFix
💎RubyGemsember-source≥ 1.8.0&&< 1.11.41.11.4bundle update ember-source --conservative
💎RubyGemsember-source≥ 1.12.0&&< 1.12.21.12.2bundle update ember-source --conservative
💎RubyGemsember-source≥ 1.13.0&&< 1.13.121.13.12bundle update ember-source --conservative
💎RubyGemsember-source≥ 2.0.0&&< 2.0.32.0.3bundle update ember-source --conservative
💎RubyGemsember-source≥ 2.1.0&&< 2.1.22.1.2bundle update ember-source --conservative
💎RubyGemsember-source≥ 2.2.0&&< 2.2.12.2.1bundle update ember-source --conservative

Affected Products

1 product · 30 configurations
Application
ember.jsemberjs
30 versions
1.81.8.11.91.9.11.101.10.11.111.11.11.11.21.11.31.121.12.1

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ember-source, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update ember-source to 1.11.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2015-7565 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Cross-site scripting (XSS) vulnerability in Ember.js 1.8.x through 1.10.x, 1.11.x before 1.11.4, 1.12.x before 1.12.2, 1.13.x before 1.13.12, 2.0.x before 2.0.3, 2.1.x before 2.1.2, and 2.2.x before 2.2.1 allows remote attackers to inject arbitrary web script or HTML.
O3 Security · Impact-Aware SCA

Is CVE-2015-7565 in your dependencies?

Find it across RubyGems, including transitive dependencies.

CVE-2015-7565: ember-source XSS — Fixed in 1.11.4