CVE-2015-1866 — ember-source
MEDIUMCVE-2015-1866 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in ember-source. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for ember-source — see the affected versions and patch details below.
ember-source vulnerable to Cross-site Scripting
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
ember-source💎ember-sourceReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.
Description
Cross-site scripting (XSS) vulnerability in Ember.js 1.10.x before 1.10.1 and 1.11.x before 1.11.2.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 💎RubyGems | ember-source | ≥ 1.10.0&&< 1.10.1 | 1.10.1bundle update ember-source --conservative |
| 💎RubyGems | ember-source | ≥ 1.11.0&&< 1.11.2 | 1.11.2bundle update ember-source --conservative |
Affected Products
ember.jsemberjsResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ember-source, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update ember-source to 1.10.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2015-1866 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2015-1866 in your dependencies?
Find it across RubyGems, including transitive dependencies.