NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
💎 RubyGems
Not in CISA KEV

CVE-2014-0046 — ember-source

Fix: emberjs/ember.js@45ee8df

CVE-2014-0046 is a Cross-site Scripting (XSS) vulnerability in ember-source. A fix is available for ember-source — see the affected versions and patch details below.

ember-source Cross-site Scripting vulnerability

Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs74th percentile — riskier than 74% of all scored CVEsHighest risk
0.00%0.67%1.34%2.00%0.4%1.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

3 pkgs affected
💎ember-source💎ember-source💎ember-source

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.

Description

Cross-site scripting (XSS) vulnerability in the link-to helper in Ember.js 1.2.x before 1.2.2, 1.3.x before 1.3.2, and 1.4.x before 1.4.0-beta.6, when used in non-block form, allows remote attackers to inject arbitrary web script or HTML via the title attribute.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
💎RubyGemsember-source≥ 1.2.0&&< 1.2.21.2.2bundle update ember-source --conservative
💎RubyGemsember-source≥ 1.3.0&&< 1.3.21.3.2bundle update ember-source --conservative
💎RubyGemsember-source≥ 1.4.0.beta.1&&< 1.4.0.beta.61.4.0.beta.6bundle update ember-source --conservative

Affected Products

1 product · 5 configurations
Application
ember.jsemberjs
5 versions
1.2.01.2.11.3.01.3.11.4.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ember-source, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update ember-source to 1.2.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2014-0046 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Cross-site scripting (XSS) vulnerability in the link-to helper in Ember.js 1.2.x before 1.2.2, 1.3.x before 1.3.2, and 1.4.x before 1.4.0-beta.6, when used in non-block form, allows remote attackers to inject arbitrary web script or HTML via the title attribute.
O3 Security · Impact-Aware SCA

Is CVE-2014-0046 in your dependencies?

Find it across RubyGems, including transitive dependencies.

CVE-2014-0046: ember-source XSS — Fixed in 1.2.2