NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
💎
💎 RubyGems
Not in CISA KEV
MEDIUM severity

CVE-2014-0013 — ember-source

MEDIUM

CVE-2014-0013 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in ember-source. A fix is available for ember-source — see the affected versions and patch details below.

Ember.js Cross-site Scripting vulnerability

Published
Updated
Affected
5 pkgs
Patched
5 / 5
Exploits
None indexed
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs52th percentile — riskier than 52% of all scored CVEsHighest risk
0.00%0.40%0.79%1.19%0.2%0.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

5 pkgs affected
💎ember-source💎ember-source💎ember-source💎ember-source💎ember-source

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.

Description

Ember.js 1.0.x before 1.0.1, 1.1.x before 1.1.3, 1.2.x before 1.2.1, 1.3.x before 1.3.1, and 1.4.x before 1.4.0-beta.2 allows remote attackers to conduct cross-site scripting (XSS) attacks by leveraging an application that contains templates whose context is set to a user-supplied primitive value and also contain the {{this}} special Handlebars variable.

Affected Packages

5 total 5 fixed
EcosystemPackageVulnerable rangeFix
💎RubyGemsember-source≥ 1.0.0.pre4.0&&< 1.0.11.0.1bundle update ember-source --conservative
💎RubyGemsember-source≥ 1.1.0&&< 1.1.31.1.3bundle update ember-source --conservative
💎RubyGemsember-source≥ 1.2.0.beta.1&&< 1.2.11.2.1bundle update ember-source --conservative
💎RubyGemsember-source≥ 1.3.0.beta.1&&< 1.3.11.3.1bundle update ember-source --conservative
💎RubyGemsember-source≥ 1.4.0-beta.1&&< 1.4.0-beta.21.4.0-beta.2bundle update ember-source --conservative

Affected Products

1 product · 38 configurations
Application
ember.jsemberjs
7 versions
1.0.01.1.01.1.11.1.21.2.01.3.01.4.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ember-source, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update ember-source to 1.0.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2014-0013 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Ember.js 1.0.x before 1.0.1, 1.1.x before 1.1.3, 1.2.x before 1.2.1, 1.3.x before 1.3.1, and 1.4.x before 1.4.0-beta.2 allows remote attackers to conduct cross-site scripting (XSS) attacks by leveraging an application that contains templates whose context is set to a user-supplied primitive value and also contain the `{{this}}` special Handlebars variable.
O3 Security · Impact-Aware SCA

Is CVE-2014-0013 in your dependencies?

Find it across RubyGems, including transitive dependencies.

CVE-2014-0013: ember-source XSS — Fixed in 1.0.1