NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

CVE-2015-5607 — ipython

HIGHFix: ipython/ipython@1415a97

CVE-2015-5607 is a high-severity (CVSS 8.8) Cross-Site Request Forgery (CSRF) vulnerability in ipython. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for ipython — see the affected versions and patch details below.

IPython vulnerable to cross site request forgery (CSRF)

Also known asGHSA-7fc2-rm35-2pp7PYSEC-2017-47
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
1 known
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs68th percentile — riskier than 68% of all scored CVEsHighest risk
0.00%0.57%1.14%1.71%0.3%1.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
🐍ipython🐍ipython

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

IPython (Interactive Python) is a command shell. Cross-site request forgery in the REST API is possible in in IPython 2 and 3. Versions 2.4.1 and 3.2.3 contain patches.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIipython≥ 0.12&&< 2.4.12.4.1pip install --upgrade 'ipython==2.4.1'
🐍PyPIipython≥ 3.0.0&&< 3.2.33.2.3pip install --upgrade 'ipython==3.2.3'

Affected Products

2 products · 15 configurations
OS
fedorafedoraproject
2 versions
2122
Application
ipythonipython
13 versions
2.0.02.1.02.2.02.3.02.3.12.4.02.4.13.0.03.1.03.2.03.2.13.2.2
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ipython, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update ipython to 2.4.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2015-5607 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

IPython (Interactive Python) is a command shell. Cross-site request forgery in the REST API is possible in in IPython 2 and 3. Versions 2.4.1 and 3.2.3 contain patches.
O3 Security · Impact-Aware SCA

Is CVE-2015-5607 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2015-5607: ipython CSRF — Fixed in 2.4.1