CVE-2014-3429 is a critical-severity (CVSS 9.8) Code Injection vulnerability in ipython. A fix is available for ipython — see the affected versions and patch details below.
IPython Notebook vulnerable to improper validation of the origin of websocket requests
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
ipythonReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
IPython Notebook 0.12 through 1.x before 1.2 does not validate the origin of websocket requests, which allows remote attackers to execute arbitrary code by leveraging knowledge of the kernel id and a crafted page.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | ipython | ≥ 0.12&&< 1.2.0 | 1.2.0pip install --upgrade 'ipython==1.2.0' |
Affected Products
ipython notebookipythonmageiamageiaopensuseopensuseDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ipython, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update ipython to 1.2.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2014-3429 is resolved across your whole dependency graph.
Workarounds
Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.
Frequently Asked Questions
Is CVE-2014-3429 in your dependencies?
Find it across PyPI, including transitive dependencies.