NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
CRITICAL severity

CVE-2015-7337 — notebook

CRITICALFix: ipython/ipython@0a8096a

CVE-2015-7337 is a critical-severity (CVSS 9.8) Improper Input Validation vulnerability in notebook. A fix is available for notebook — see the affected versions and patch details below.

Improper Input Validation in Jupyter Notebook

Also known asPYSEC-2015-25PYSEC-2015-27
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs85th percentile — riskier than 85% of all scored CVEsHighest risk
0.26%1.17%2.09%3.00%0.8%2.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
🐍notebook🐍ipython

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

The editor in IPython Notebook before 3.2.2 and Jupyter Notebook 4.0.x before 4.0.5 allows remote attackers to execute arbitrary JavaScript code via a crafted file, which triggers a redirect to files/, related to MIME types.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPInotebook≥ 4.0.0&&< 4.0.54.0.5pip install --upgrade 'notebook==4.0.5'
🐍PyPIipythonall versions3.2.2pip install --upgrade 'ipython==3.2.2'

Affected Products

2 products · 6 configurations
Application
notebookipython
≤ 3.2.1
range
Application
notebookjupyter
5 versions
4.0.04.0.14.0.24.0.34.0.4

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for notebook, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update notebook to 4.0.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2015-7337 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

The editor in IPython Notebook before 3.2.2 and Jupyter Notebook 4.0.x before 4.0.5 allows remote attackers to execute arbitrary JavaScript code via a crafted file, which triggers a redirect to files/, related to MIME types.
O3 Security · Impact-Aware SCA

Is CVE-2015-7337 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2015-7337: notebook — Fixed in 4.0.5