NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

CVE-2015-6938 — notebook

MEDIUMFix: jupyter/notebook@dd98763

CVE-2015-6938 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in notebook. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for notebook — see the affected versions and patch details below.

Improper Neutralization of Input During Web Page Generation in Jupyter Notebook

Also known asGHSA-4vwq-x64q-j4cjPYSEC-2015-24PYSEC-2015-26
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
2 known
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs86th percentile — riskier than 86% of all scored CVEsHighest risk
0.28%1.31%2.34%3.37%0.9%2.8%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
🐍notebook🐍ipython

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Cross-site scripting (XSS) vulnerability in the file browser in notebook/notebookapp.py in IPython Notebook before 3.2.2 and Jupyter Notebook 4.0.x before 4.0.5 allows remote attackers to inject arbitrary web script or HTML via a folder name. NOTE: this was originally reported as a cross-site request forgery (CSRF) vulnerability, but this may be inaccurate.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPInotebook≥ 4.0.0&&< 4.0.54.0.5pip install --upgrade 'notebook==4.0.5'
🐍PyPIipythonall versions3.2.2pip install --upgrade 'ipython==3.2.2'

Affected Products

4 products · 11 configurations
OS
fedorafedoraproject
3 versions
212223
Application
notebookipython
≤ 3.2.1
range
Application
notebookjupyter
5 versions
4.0.04.0.14.0.24.0.34.0.4
OS
opensuseopensuse
2 versions
13.113.2
Exploits & PoCs
2

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for notebook, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update notebook to 4.0.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2015-6938 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Cross-site scripting (XSS) vulnerability in the file browser in notebook/notebookapp.py in IPython Notebook before 3.2.2 and Jupyter Notebook 4.0.x before 4.0.5 allows remote attackers to inject arbitrary web script or HTML via a folder name. NOTE: this was originally reported as a cross-site request forgery (CSRF) vulnerability, but this may be inaccurate.
O3 Security · Impact-Aware SCA

Is CVE-2015-6938 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2015-6938: notebook XSS — Fixed in 4.0.5