CVE-2015-5254 is a critical-severity (CVSS 9.8) Improper Input Validation vulnerability in org.apache.activemq:activemq-client. 6 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for org.apache.activemq:activemq-client — see the affected versions and patch details below.
Improper Input Validation in Apache ActiveMQ
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.activemq:activemq-client☕org.apache.activemq:activemq-clientReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Apache ActiveMQ 5.x before 5.13.0 does not restrict the classes that can be serialized in the broker, which allows remote attackers to execute arbitrary code via a crafted serialized Java Message Service (JMS) ObjectMessage object.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.activemq:activemq-client | ≥ 5.0.0&&< 5.11.3 | 5.11.3org.apache.activemq:activemq-client:5.11.3 |
| ☕Maven | org.apache.activemq:activemq-client | ≥ 5.12.0&&< 5.12.2 | 5.12.2org.apache.activemq:activemq-client:5.12.2 |
Affected Products
activemqapachefedorafedoraprojectopenshiftredhatResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.activemq:activemq-client, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.activemq:activemq-client to 5.11.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2015-5254 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
A malicious message producer needs to authenticate to EAP in order to send messages. Also, the use of JMS ObjectMessage needs to be chosen by the developer of the application. Therefore this issue is rated as moderate.
If you do deploy a JMS publisher, and subscriber, and don't trust the messages sent to you by your clients, you could mitigate this issue by installing a Java agent which restricts the classes which can be deserialized. This is an article with the recommended approach: https://access.redhat.com/solutions/2190911 You could also mitigate this issue using the features of the Java Virtual Machine added in JEP 290: http://openjdk.java.net/jeps/290Source: Red Hat security advisory for CVE-2015-5254 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat JBoss A-MQ 6.3 | see advisory | RHSA-2016:2036 |
| Red Hat JBoss Fuse 6.3 | see advisory | RHSA-2016:2035 |
| Red Hat OpenShift Enterprise 2.2 | activemq-0:5.9.0-6.redhat.611454.el6op | RHSA-2016:0489 |
Frequently Asked Questions
Is CVE-2015-5254 in your dependencies?
Find it across Maven, including transitive dependencies.