CVE-2015-5174 — tomcat
MEDIUMCVE-2015-5174 is a medium-severity (CVSS 4.3) Path Traversal vulnerability in org.apache.tomcat:tomcat. EPSS puts its 30-day exploitation probability at 12.6% (96th percentile). A fix is available for org.apache.tomcat:tomcat — see the affected versions and patch details below.
Improper Limitation of a Pathname to a Restricted Directory in Apache Tomcat
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2015-5174.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.tomcat:tomcat☕org.apache.tomcat:tomcat☕org.apache.tomcat:tomcatReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Directory traversal vulnerability in RequestUtil.java in Apache Tomcat 6.x before 6.0.45, 7.x before 7.0.65, and 8.x before 8.0.27 allows remote authenticated users to bypass intended SecurityManager restrictions and list a parent directory via a /.. (slash dot dot) in a pathname used by a web application in a getResource, getResourceAsStream, or getResourcePaths call, as demonstrated by the $CATALINA_BASE/webapps directory.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.tomcat:tomcat | ≥ 8.0.0-RC1&&< 8.0.27 | 8.0.27org.apache.tomcat:tomcat:8.0.27 |
| ☕Maven | org.apache.tomcat:tomcat | ≥ 7.0.0&&< 7.0.65 | 7.0.65org.apache.tomcat:tomcat:7.0.65 |
| ☕Maven | org.apache.tomcat:tomcat | ≥ 6.0.0&&< 6.0.45 | 6.0.45org.apache.tomcat:tomcat:6.0.45 |
Affected Products
tomcatapacheubuntu linuxcanonicaldebian linuxdebianDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.tomcat:tomcat, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.tomcat:tomcat to 8.0.27 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2015-5174 is resolved across your whole dependency graph.
Workarounds
Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Enterprise Linux 6 | tomcat6-0:6.0.24-98.el6_8 | RHSA-2016:2045 |
| Red Hat Enterprise Linux 7 | tomcat-0:7.0.69-10.el7 | RHSA-2016:2599 |
| Red Hat JBoss Enterprise Application Platform 6.4 | see advisory | RHSA-2016:1435 |
| Red Hat JBoss Enterprise Application Platform 6.4 for RHEL 6 | jboss-ec2-eap-0:7.5.9-2.Final_redhat_2.ep6.el6 | RHSA-2016:1432 |
| Red Hat JBoss Enterprise Application Platform 6.4 for RHEL 6 | apache-cxf-0:2.7.18-2.SP1_redhat_1.1.ep6.el6 | RHSA-2016:1433 |
| Red Hat JBoss Enterprise Application Platform 6.4 for RHEL 7 | apache-cxf-0:2.7.18-2.SP1_redhat_1.1.ep6.el7 | RHSA-2016:1434 |
| Red Hat JBoss Enterprise Web Server 2 for RHEL 5 | tomcat7-0:7.0.54-21_patch_05.ep6.el5 | RHBA-2016:0090 |
| Red Hat JBoss Web Server 3.0 | see advisory | RHSA-2015:2661 |
Frequently Asked Questions
Is CVE-2015-5174 in your dependencies?
Find it across Maven, including transitive dependencies.