NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘 Packagist
Not in CISA KEV

CVE-2015-2068 — magmi

CVE-2015-2068 is a Cross-site Scripting (XSS) vulnerability in dweeves/magmi. 3 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for dweeves/magmi — see the affected versions and patch details below.

MAGMI cross-site scripting (XSS)

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
3 known
Exploitation data as of Oct 31, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
14.0%probability of exploitation in next 30 days
Moderate Risk0.00%
Lower risk than most CVEs97th percentile — riskier than 97% of all scored CVEsHighest risk
0.00%5.89%11.8%17.7%1.9%14.0%May 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected
🐘dweeves/magmi

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Multiple cross-site scripting (XSS) vulnerabilities in the MAGMI (aka Magento Mass Importer) plugin for Magento Server allow remote attackers to inject arbitrary web script or HTML via the (1) profile parameter to web/magmi.php or (2) QUERY_STRING to web/magmi_import_run.php.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistdweeves/magmiall versions0.7.22composer require dweeves/magmi:^0.7.22

Affected Products

1 product · 1 configurations
Application
magmimagmi_project
all
Exploits & PoCs
3

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

EDB-35996webappsphp

Magento Server MAGMI Plugin - Multiple Vulnerabilities

by SECUPENT · Feb 5, 2015

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for dweeves/magmi, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update dweeves/magmi to 0.7.22 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2015-2068 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

How to detect CVE-2015-2068

A community-maintained Nuclei template exists for this CVE. You can scan for it directly:

nuclei -id cve-2015-2068 -u https://target
Template
Magento Server Mass Importer - Cross-Site Scripting
Severity
medium
Impact
Successful exploitation of this vulnerability could allow an attacker to inject malicious scripts into web pages viewed by users, leading to potential data theft, session hijacking, or defacement of the affected Magento server.
Remediation
Apply the latest security patches provided by Magento to fix the XSS vulnerability in the Server Mass Importer module.

Template by ProjectDiscovery nuclei-templates (daffainfo), MIT licensed. View the full template. Scan only systems you are authorised to test.

Frequently Asked Questions

Multiple cross-site scripting (XSS) vulnerabilities in the MAGMI (aka Magento Mass Importer) plugin for Magento Server allow remote attackers to inject arbitrary web script or HTML via the (1) profile parameter to web/magmi.php or (2) QUERY_STRING to web/magmi_import_run.php.
O3 Security · Impact-Aware SCA

Is CVE-2015-2068 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2015-2068: magmi XSS — Fixed in 0.7.22