CVE-2017-7391 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in dweeves/magmi. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for dweeves/magmi — see the affected versions and patch details below.
Magmi XSS Vulnerability
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
dweeves/magmiReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
A Cross-Site Scripting (XSS) was discovered in 'Magmi 0.7.22'. The vulnerability exists due to insufficient filtration of user-supplied data (prefix) passed to the 'magmi-git-master/magmi/web/ajax_gettime.php' URL. An attacker could execute arbitrary HTML and script code in a browser in the context of the vulnerable website.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | dweeves/magmi | all versions | 0.7.24composer require dweeves/magmi:^0.7.24 |
Affected Products
magmimagmi_projectResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for dweeves/magmi, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update dweeves/magmi to 0.7.24 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-7391 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
How to detect CVE-2017-7391
A community-maintained Nuclei template exists for this CVE. You can scan for it directly:
nuclei -id cve-2017-7391 -u https://target- Template
- Magmi 0.7.22 - Cross-Site Scripting
- Severity
- medium
- Impact
- Successful exploitation of this vulnerability could allow an attacker to execute arbitrary JavaScript code in the context of the victim's browser, leading to session hijacking, defacement, or theft of sensitive information.
- Remediation
- Upgrade to a patched version of Magmi or apply the necessary security patches to mitigate the XSS vulnerability.
Template by ProjectDiscovery nuclei-templates (pikpikcu), MIT licensed. View the full template. Scan only systems you are authorised to test.
Frequently Asked Questions
Is CVE-2017-7391 in your dependencies?
Find it across Packagist, including transitive dependencies.