CVE-2020-5777 is a critical-severity (CVSS 9.8) Improper Authentication vulnerability in dweeves/magmi. EPSS puts its 30-day exploitation probability at 23.3% (98th percentile). A fix is available for dweeves/magmi — see the affected versions and patch details below.
Authentication bypass in MAGMI
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
dweeves/magmiReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
MAGMI versions prior to 0.7.24 are vulnerable to a remote authentication bypass due to allowing default credentials in the event there is a database connection failure. A remote attacker can trigger this connection failure if the Mysql setting max_connections (default 151) is lower than Apache (or another web server) setting MaxRequestWorkers (formerly MaxClients) (default 256). This can be done by sending at least 151 simultaneous requests to the Magento website to trigger a "Too many connections" error, then use default magmi:magmi basic authentication to remotely bypass authentication.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | dweeves/magmi | all versions | 0.7.24composer require dweeves/magmi:^0.7.24 |
Affected Products
magmimagmi_projectDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for dweeves/magmi, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update dweeves/magmi to 0.7.24 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-5777 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
How to detect CVE-2020-5777
A community-maintained Nuclei template exists for this CVE. You can scan for it directly:
nuclei -id cve-2020-5777 -u https://target- Template
- Magento Mass Importer <0.7.24 - Remote Auth Bypass
- Severity
- critical
- Impact
- An attacker can bypass authentication and gain unauthorized access to the Magento Mass Importer plugin.
- Remediation
- Upgrade to version 0.7.24 or later to fix the authentication bypass vulnerability.
Template by ProjectDiscovery nuclei-templates (dwisiswant0), MIT licensed. View the full template. Scan only systems you are authorised to test.
Frequently Asked Questions
Is CVE-2020-5777 in your dependencies?
Find it across Packagist, including transitive dependencies.