CVE-2014-7810 — tomcat
CVE-2014-7810 is a CWE-284 vulnerability in org.apache.tomcat:tomcat. EPSS puts its 30-day exploitation probability at 13.3% (96th percentile). A fix is available for org.apache.tomcat:tomcat — see the affected versions and patch details below.
Improper Access Control in Apache Tomcat
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2014-7810.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
org.apache.tomcat:tomcat☕org.apache.tomcat:tomcat☕org.apache.tomcat:tomcatReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
The Expression Language (EL) implementation in Apache Tomcat 6.x before 6.0.44, 7.x before 7.0.58, and 8.x before 8.0.16 does not properly consider the possibility of an accessible interface implemented by an inaccessible class, which allows attackers to bypass a SecurityManager protection mechanism via a web application that leverages use of incorrect privileges during EL evaluation.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.tomcat:tomcat | ≥ 6.0.0&&< 6.0.44 | 6.0.44org.apache.tomcat:tomcat:6.0.44 |
| ☕Maven | org.apache.tomcat:tomcat | ≥ 7.0.0&&< 7.0.58 | 7.0.58org.apache.tomcat:tomcat:7.0.58 |
| ☕Maven | org.apache.tomcat:tomcat | ≥ 8.0.0&&< 8.0.16 | 8.0.16org.apache.tomcat:tomcat:8.0.16 |
Affected Products
tomcatapachedebian linuxdebianDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.tomcat:tomcat, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.tomcat:tomcat to 6.0.44 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2014-7810 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Enterprise Linux 6 | tomcat6-0:6.0.24-94.el6_7 | RHSA-2016:0492 |
| Red Hat Enterprise Linux 7 | tomcat-0:7.0.54-8.el7_2 | RHSA-2016:2046 |
| Red Hat JBoss Enterprise Web Server 2 for RHEL 5 | tomcat6-0:6.0.41-15_patch_04.ep6.el5 | RHSA-2015:1622 |
| Red Hat JBoss Web Server 2.1 | see advisory | RHSA-2015:1621 |
Frequently Asked Questions
Is CVE-2014-7810 in your dependencies?
Find it across Maven, including transitive dependencies.