NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕ Maven
Not in CISA KEV

CVE-2014-3612 — activemq-broker

Fix: apache/activemq@22f2f3d

CVE-2014-3612 is a Improper Authentication vulnerability in org.apache.activemq:activemq-broker. A fix is available for org.apache.activemq:activemq-broker — see the affected versions and patch details below.

Improper Authentication in Apache WSS4J

Also known asGHSA-72m6-23ff-7q26
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
6.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs94th percentile — riskier than 94% of all scored CVEsHighest risk
0.00%3.13%6.25%9.38%0.7%6.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

2 pkgs affected
☕org.apache.activemq:activemq-broker☕org.apache.activemq:activemq-jaas

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

The LDAPLoginModule implementation in the Java Authentication and Authorization Service (JAAS) in Apache ActiveMQ 5.x before 5.10.1 allows remote attackers to bypass authentication by logging in with an empty password and valid username, which triggers an unauthenticated bind. NOTE: this identifier has been SPLIT per ADT2 due to different vulnerability types. See CVE-2015-6524 for the use of wildcard operators in usernames.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.activemq:activemq-broker≥ 5.0.0&&< 5.10.15.10.1org.apache.activemq:activemq-broker:5.10.1
☕Mavenorg.apache.activemq:activemq-jaas≥ 5.0.0&&< 5.10.15.10.1org.apache.activemq:activemq-jaas:5.10.1

Affected Products

1 product · 18 configurations
Application
activemqapache
18 versions
5.0.05.1.05.2.05.3.05.3.15.3.25.4.05.4.15.4.25.4.35.5.05.5.1

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.activemq:activemq-broker, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.activemq:activemq-broker to 5.10.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2014-3612 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Frequently Asked Questions

The LDAPLoginModule implementation in the Java Authentication and Authorization Service (JAAS) in Apache ActiveMQ 5.x before 5.10.1 allows remote attackers to bypass authentication by logging in with an empty password and valid username, which triggers an unauthenticated bind. NOTE: this identifier has been SPLIT per ADT2 due to different vulnerability types. See CVE-2015-6524 for the use of wildcard operators in usernames.
O3 Security · Impact-Aware SCA

Is CVE-2014-3612 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2014-3612: activemq-broker — Fixed in 5.10.1