CVE-2014-0230 — tomcat
Fix: apache/tomcat@6b2cfacCVE-2014-0230 is a CWE-399 vulnerability in org.apache.tomcat:tomcat. EPSS puts its 30-day exploitation probability at 20.2% (97th percentile). A fix is available for org.apache.tomcat:tomcat — see the affected versions and patch details below.
Uncontrolled Resource Consumption in Apache Tomcat
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2014-0230.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
org.apache.tomcat:tomcat☕org.apache.tomcat:tomcat☕org.apache.tomcat:tomcatReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Apache Tomcat 6.x before 6.0.44, 7.x before 7.0.55, and 8.x before 8.0.9 does not properly handle cases where an HTTP response occurs before finishing the reading of an entire request body, which allows remote attackers to cause a denial of service (thread consumption) via a series of aborted upload attempts.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.tomcat:tomcat | ≥ 6.0.0&&< 6.0.44 | 6.0.44org.apache.tomcat:tomcat:6.0.44 |
| ☕Maven | org.apache.tomcat:tomcat | ≥ 7.0.0&&< 7.0.55 | 7.0.55org.apache.tomcat:tomcat:7.0.55 |
| ☕Maven | org.apache.tomcat:tomcat | ≥ 8.0.0&&< 8.0.9 | 8.0.9org.apache.tomcat:tomcat:8.0.9 |
Affected Products
tomcatapachevirtualizationoracleDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.tomcat:tomcat, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.tomcat:tomcat to 6.0.44 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2014-0230 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Enterprise Linux 7 | tomcat-0:7.0.69-10.el7 | RHSA-2016:2599 |
| Red Hat JBoss Enterprise Application Platform 6.4 | see advisory | RHSA-2016:0599 |
| Red Hat JBoss Enterprise Application Platform 6.4 for RHEL 5 | glassfish-jsf-eap6-0:2.1.28-10.SP9_redhat_1.1.ep6.el5 | RHSA-2016:0595 |
| Red Hat JBoss Enterprise Application Platform 6.4 for RHEL 6 | glassfish-jsf-eap6-0:2.1.28-10.SP9_redhat_1.1.ep6.el6 | RHSA-2016:0596 |
| Red Hat JBoss Enterprise Application Platform 6.4 for RHEL 6 | jboss-ec2-eap-0:7.5.7-2.Final_redhat_3.ep6.el6 | RHSA-2016:0598 |
| Red Hat JBoss Enterprise Application Platform 6.4 for RHEL 7 | glassfish-jsf-eap6-0:2.1.28-10.SP9_redhat_1.1.ep6.el7 | RHSA-2016:0597 |
| Red Hat JBoss Enterprise Web Server 2 for RHEL 5 | tomcat6-0:6.0.41-15_patch_04.ep6.el5 | RHSA-2015:1622 |
| Red Hat JBoss Web Server 2.1 | see advisory | RHSA-2015:1621 |
Frequently Asked Questions
Is CVE-2014-0230 in your dependencies?
Find it across Maven, including transitive dependencies.