CVE-2014-0227 — tomcat
Fix: apache/tomcat@593a244CVE-2014-0227 is a CWE-19 vulnerability in org.apache.tomcat:tomcat. EPSS puts its 30-day exploitation probability at 21.0% (98th percentile). A fix is available for org.apache.tomcat:tomcat — see the affected versions and patch details below.
Improper Input Validation in Apache Tomcat
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2014-0227.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
org.apache.tomcat:tomcat☕org.apache.tomcat:tomcat☕org.apache.tomcat:tomcatReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
java/org/apache/coyote/http11/filters/ChunkedInputFilter.java in Apache Tomcat 6.x before 6.0.42, 7.x before 7.0.55, and 8.x before 8.0.9 does not properly handle attempts to continue reading data after an error has occurred, which allows remote attackers to conduct HTTP request smuggling attacks or cause a denial of service (resource consumption) by streaming data with malformed chunked transfer coding.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.tomcat:tomcat | ≥ 6.0.0&&< 6.0.42 | 6.0.42org.apache.tomcat:tomcat:6.0.42 |
| ☕Maven | org.apache.tomcat:tomcat | ≥ 7.0.0&&< 7.0.55 | 7.0.55org.apache.tomcat:tomcat:7.0.55 |
| ☕Maven | org.apache.tomcat:tomcat | ≥ 8.0.0&&< 8.0.9 | 8.0.9org.apache.tomcat:tomcat:8.0.9 |
Affected Products
tomcatapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.tomcat:tomcat, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.tomcat:tomcat to 6.0.42 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2014-0227 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Enterprise Linux 6 | tomcat6-0:6.0.24-83.el6_6 | RHSA-2015:0991 |
| Red Hat Enterprise Linux 7 | tomcat-0:7.0.54-2.ael7b_1 | RHSA-2015:0983 |
| Red Hat JBoss BPMS 6.0 | see advisory | RHSA-2015:0234 |
| Red Hat JBoss BRMS 6.0 | see advisory | RHSA-2015:0235 |
| Red Hat JBoss Data Grid 6.4 | see advisory | RHSA-2015:0091 |
| Red Hat JBoss Data Virtualization 6.0 | see advisory | RHSA-2015:0765 |
| Red Hat JBoss Data Virtualization 6.1 | see advisory | RHSA-2015:0675 |
| Red Hat JBoss Enterprise Application Platform 6.3 | see advisory | RHSA-2014:1021 |
Frequently Asked Questions
Is CVE-2014-0227 in your dependencies?
Find it across Maven, including transitive dependencies.