CVE-2014-0096 — tomcat
Fix: apache/tomcat@3c53c4dCVE-2014-0096 is a CWE-264 vulnerability in org.apache.tomcat:tomcat. A fix is available for org.apache.tomcat:tomcat — see the affected versions and patch details below.
Improper Input Validation in Apache Tomcat
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2014-0096.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
org.apache.tomcat:tomcat☕org.apache.tomcat:tomcat☕org.apache.tomcat:tomcat☕org.apache.tomcat:tomcat-catalina☕org.apache.tomcat:tomcat-catalina☕org.apache.tomcat:tomcat-catalinaReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
java/org/apache/catalina/servlets/DefaultServlet.java in the default servlet in Apache Tomcat before 6.0.40, 7.x before 7.0.53, and 8.x before 8.0.4 does not properly restrict XSLT stylesheets, which allows remote attackers to bypass security-manager restrictions and read arbitrary files via a crafted web application that provides an XML external entity declaration in conjunction with an entity reference, related to an XML External Entity (XXE) issue.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.tomcat:tomcat | all versions | 6.0.40org.apache.tomcat:tomcat:6.0.40 |
| ☕Maven | org.apache.tomcat:tomcat | ≥ 7.0.0&&< 7.0.54 | 7.0.54org.apache.tomcat:tomcat:7.0.54 |
| ☕Maven | org.apache.tomcat:tomcat | ≥ 8.0.0&&< 8.0.6 | 8.0.6org.apache.tomcat:tomcat:8.0.6 |
| ☕Maven | org.apache.tomcat:tomcat-catalina | all versions | 6.0.40org.apache.tomcat:tomcat-catalina:6.0.40 |
| ☕Maven | org.apache.tomcat:tomcat-catalina | ≥ 7.0.0&&< 7.0.54 | 7.0.54org.apache.tomcat:tomcat-catalina:7.0.54 |
| ☕Maven | org.apache.tomcat:tomcat-catalina | ≥ 8.0.0&&< 8.0.6 | 8.0.6org.apache.tomcat:tomcat-catalina:8.0.6 |
Affected Products
tomcatapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.tomcat:tomcat, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.tomcat:tomcat to 6.0.40 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2014-0096 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
This issue does affect JBossWeb as shipped in Red Hat JBoss Enterprise Application Platform 5. Red Hat Product Security has rated this issue as having Low security impact. Red Hat JBoss Enterprise Application Platform 5 is currently in reduced support phase (Phase 2: Maintenance Support), receiving only Critical and…
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Enterprise Linux 6 | tomcat6-0:6.0.24-72.el6_5 | RHSA-2014:0865 |
| Red Hat Enterprise Linux 7 | tomcat-0:7.0.42-6.el7_0 | RHSA-2014:0827 |
| Red Hat JBoss BPMS 6.0 | jbossweb | RHSA-2015:0234 |
| Red Hat JBoss BRMS 6.0 | jbossweb | RHSA-2015:0235 |
| Red Hat JBoss Data Grid 6.3 | jbossweb | RHSA-2014:0895 |
| Red Hat JBoss Data Virtualization 6.0 | jbossweb | RHSA-2015:0765 |
| Red Hat JBoss Data Virtualization 6.1 | see advisory | RHSA-2015:0675 |
| Red Hat JBoss Enterprise Application Platform 6.2 | see advisory | RHSA-2014:0842 |
Frequently Asked Questions
Is CVE-2014-0096 in your dependencies?
Find it across Maven, including transitive dependencies.