CVE-2013-4286 — tomcat
Fix: apache/tomcat@41b90b6CVE-2013-4286 is a Improper Input Validation vulnerability in org.apache.tomcat:tomcat. EPSS puts its 30-day exploitation probability at 16.2% (97th percentile). A fix is available for org.apache.tomcat:tomcat — see the affected versions and patch details below.
Apache Tomcat is vulnerable to HTTP request-smuggling
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2013-4286.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
org.apache.tomcat:tomcat☕org.apache.tomcat:tomcat☕org.apache.tomcat:tomcatReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Apache Tomcat before 6.0.39, 7.x before 7.0.47, and 8.x before 8.0.0-RC3, when an HTTP connector or AJP connector is used, does not properly handle certain inconsistent HTTP request headers, which allows remote attackers to trigger incorrect identification of a request's length and conduct request-smuggling attacks via (1) multiple Content-Length headers or (2) a Content-Length header and a "Transfer-Encoding: chunked" header. NOTE: this vulnerability exists because of an incomplete fix for CVE-2005-2090.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.tomcat:tomcat | all versions | 6.0.39org.apache.tomcat:tomcat:6.0.39 |
| ☕Maven | org.apache.tomcat:tomcat | ≥ 7.0.0&&< 7.0.47 | 7.0.47org.apache.tomcat:tomcat:7.0.47 |
| ☕Maven | org.apache.tomcat:tomcat | ≥ 8.0.0-RC1&&< 8.0.0-RC3 | 8.0.0-RC3org.apache.tomcat:tomcat:8.0.0-RC3 |
Affected Products
tomcatapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.tomcat:tomcat, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.tomcat:tomcat to 6.0.39 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2013-4286 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Enterprise Linux 6 | tomcat6-0:6.0.24-64.el6_5 | RHSA-2014:0429 |
| Red Hat Enterprise Linux 7 | tomcat-0:7.0.42-5.el7_0 | RHSA-2014:0686 |
| Red Hat JBoss BPMS 6.0 | jbossweb | RHSA-2014:0373 |
| Red Hat JBoss Data Grid 6.2 | jbossweb | RHSA-2014:0374 |
| Red Hat JBoss Data Virtualization 6.0 | jbossweb | RHSA-2014:0458 |
| Red Hat JBoss Enterprise Application Platform 6.2 | jbossweb | RHSA-2014:0345 |
| Red Hat JBoss Enterprise Application Platform 6.2 for RHEL 5 | apache-cxf-0:2.7.10-1.redhat_1.1.ep6.el5 | RHSA-2014:0343 |
| Red Hat JBoss Enterprise Application Platform 6.2 for RHEL 6 | apache-cxf-0:2.7.10-1.redhat_1.1.ep6.el6 | RHSA-2014:0344 |
Frequently Asked Questions
Is CVE-2013-4286 in your dependencies?
Find it across Maven, including transitive dependencies.