CVE-2013-2071 — tomcat
CVE-2013-2071 is a Information Exposure vulnerability in org.apache.tomcat:tomcat. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for org.apache.tomcat:tomcat — see the affected versions and patch details below.
Exposure of Sensitive Information to an Unauthorized Actor in Apache Tomcat
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
org.apache.tomcat:tomcatReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
java/org/apache/catalina/core/AsyncContextImpl.java in Apache Tomcat 7.x before 7.0.40 does not properly handle the throwing of a RuntimeException in an AsyncListener in an application, which allows context-dependent attackers to obtain sensitive request information intended for other applications in opportunistic circumstances via an application that records the requests that it processes.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.tomcat:tomcat | ≥ 7.0.0&&< 7.0.40 | 7.0.40org.apache.tomcat:tomcat:7.0.40 |
Affected Products
tomcatapacheResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.tomcat:tomcat, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.tomcat:tomcat to 7.0.40 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2013-2071 is resolved across your whole dependency graph.
Workarounds
Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
This flaw only affects tomcat 7. Tomcat 5 and 6 are not affected. The jbossweb servlet container is also not affected.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat JBoss Enterprise Web Server 2 for RHEL 5 | apache-commons-daemon-eap6-1:1.0.15-4.redhat_1.ep6.el5 | RHSA-2013:1011 |
| Red Hat JBoss Enterprise Web Server 2 for RHEL 6 | apache-commons-daemon-eap6-1:1.0.15-4.redhat_1.ep6.el6 | RHSA-2013:1012 |
| Red Hat JBoss Web Server 2.0 | see advisory | RHSA-2013:1013 |
Frequently Asked Questions
Is CVE-2013-2071 in your dependencies?
Find it across Maven, including transitive dependencies.