CVE-2013-1840 — glance
Fix: openstack/glance@74b067dCVE-2013-1840 is a CWE-201 vulnerability in glance. A fix is available for glance — see the affected versions and patch details below.
OpenStack Glance is vulnerable to Exposure of Sensitive Information
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
glanceReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
A flaw was found in OpenStack Glance. Remote authenticated users can exploit this vulnerability by requesting a cached image when the single-tenant Swift or S3 store is in use. This action causes the system to report the location field, which can lead to the disclosure of the operator's backend credentials.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | glance | all versions | 11.0.0a0pip install --upgrade 'glance==11.0.0a0' |
Affected Products
glanceopenstackDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for glance, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update glance to 11.0.0a0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2013-1840 is resolved across your whole dependency graph.
Workarounds
Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.Source: Red Hat security advisory for CVE-2013-1840 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| OpenStack Folsom for RHEL 6 | openstack-glance-0:2012.2.3-8.el6ost | RHSA-2013:0707 |
Frequently Asked Questions
Is CVE-2013-1840 in your dependencies?
Find it across PyPI, including transitive dependencies.