CVE-2014-5356 — glance
Fix: openstack/glance@12f43cfCVE-2014-5356 is a CWE-264 vulnerability in glance. A fix is available for glance — see the affected versions and patch details below.
OpenStack Glance improper validation of the image_size_cap configuration option
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
glanceReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
OpenStack Image Registry and Delivery Service (Glance) before 2013.2.4, 2014.x before 2014.1.3, and Juno before Juno-3, when using the V2 API, does not properly enforce the image_size_cap configuration option, which allows remote authenticated users to cause a denial of service (disk consumption) by uploading a large image.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | glance | all versions | 11.0.0a0pip install --upgrade 'glance==11.0.0a0' |
Affected Products
ubuntu linuxcanonicalimage registry and delivery service \(glance\)openstackDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for glance, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update glance to 11.0.0a0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2014-5356 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| OpenStack 4 for RHEL 6 | openstack-glance-0:2013.2.4-1.el6ost | RHSA-2014:1685 |
| Red Hat Enterprise Linux OpenStack Platform 5.0 (Icehouse) for RHEL 6 | openstack-glance-0:2014.1.2-5.el6ost | RHSA-2014:1338 |
| Red Hat Enterprise Linux OpenStack Platform 5.0 (Icehouse) for RHEL 7 | openstack-glance-0:2014.1.2-3.el7ost | RHSA-2014:1337 |
Frequently Asked Questions
Is CVE-2014-5356 in your dependencies?
Find it across PyPI, including transitive dependencies.