NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍 PyPI
Not in CISA KEV

CVE-2012-4573 — glance

Fix: openstack/glance@6ab0992

CVE-2012-4573 is a CWE-264 vulnerability in glance. A fix is available for glance — see the affected versions and patch details below.

OpenStack Glance arbitrary deletion of non-protected images

Also known asGHSA-6rrm-xxvh-7r87
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
3.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs89th percentile — riskier than 89% of all scored CVEsHighest risk
0.09%1.43%2.76%4.10%0.8%3.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected
🐍glance

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

The v1 API in OpenStack Glance Grizzly, Folsom (2012.2), and Essex (2012.1) allows remote authenticated users to delete arbitrary non-protected images via an image deletion request, a different vulnerability than CVE-2012-5482.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIglanceall versions11.0.0a0pip install --upgrade 'glance==11.0.0a0'

Affected Products

3 products · 3 configurations
Application
essexopenstack
1 version
2012.1
Application
folsomopenstack
1 version
2012.2
Application
image registry and delivery service \(glance\)openstack
all

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for glance, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update glance to 11.0.0a0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2012-4573 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatLow
ProductFixed inAdvisory
OpenStack Essex for RHEL 6openstack-glance-0:2012.1.2-2.el6RHSA-2012:1558

Frequently Asked Questions

The v1 API in OpenStack Glance Grizzly, Folsom (2012.2), and Essex (2012.1) allows remote authenticated users to delete arbitrary non-protected images via an image deletion request, a different vulnerability than CVE-2012-5482.
O3 Security · Impact-Aware SCA

Is CVE-2012-4573 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2012-4573: glance — Fixed in 11.0.0a0